Showing results for 
Search instead for 
Did you mean: 

Quest 2 Air Link didn't work after update - Here's how I fixed it


After a few months i wanted to play some vr, i updated app on pc and update headset to lastests versions, now whem in trying to connect trough airlink, the button to connect to my pc either grayed out, or when it works, i starting stema vr, it either starts the app and does nothing, on pc steam vr starts up normaly and working, but doesnt see headset. or sees it, but my headset doesnt go into steam vr so i can start games from there, either it goes into steam vr with flashing screen for 4-5 seconds and then airlink closes, and doesnt let me connect back till i reset headset or oculus app on steam. It was working back thenm but now it just doesnt...

  • pc connected to internet through and ethernet cable
  • quest to on a 5ghz channel both pc and quest 2 are on the same network
  • verified that quest to will connect to pc with virtual desktop (would rather not use)
  • pc specs are :
    • windows 10
    • ryzen 5 2600
    • 32gb of ddr4 ram
    • m.2 ssd
    • Palit rtx 3060 12gb
    • 600w psu

attempted fixes:

  • restarting both pc and quest multiple times
  • reinstalling oculus software on pc side (once)
  • unpairing quest 2 to pc (will no longer pair since I cant connect headset to computer)
  • uninstalling and reinstalling network driver on pc
  • restarting router
  • forgetting and reconnecting WIFI on quest 2
  • disconnecting and reconnecting ethernet cable
  • changing computer network from public to private
  • disabling firewall and also re enabling
  • i have ran a CMD command to verify that the pc and quest 2 can communicate with each other
  • repairing oculus software

Accepted Solutions


So,  i changed my router from tplink ax53  to xiaomi ax6000 with wifi6, installed steamlink app in headset and set steamlink settings from steam support faq page, oculust vr server is disabled from startup in windows so it wont to interfere and disturb any steamlink connection< just to be safe.
after all this it works fine, works fine, some stutters here and there, but i think its steamlink problem since i can see the connections in graph window from steamlink
p.s. also some updates came for headset, mb something was fixed in them too, i didnt read

View solution in original post



i got it somewhat working, had to set steamvr into legacy patch for windows 7/8.1, tho this patch doesnt work proerly, sometimes gives errors about nut supported drivers...

Community Manager
Community Manager

Hey, @Celestin6669. Thanks for bringing this issue to our attention. We hate to hear you aren't able to connect your headset to your PC via Air Link and want to assist you in resolving things as quickly as possible. It seems like you've already tried several options, but here are a few more things to consider that might provide a better solution to the issue:


  1. Have you tried accessing the quick settings to identify the root cause of the problem? If not, we'll list the steps below. 
  2. Wireless interferences and network congestion from multiple connected devices can impact your game performance. Use step one to access Quick Settings > Discover what may be causing the issue > use this link to troubleshoot the issue. 
  3. You may need consider updating your graphics driver as well. 

The steps to the first option are as follows: 

  • Put on your headset.
  • Press / on your right Touch controller to pull up your universal menu.
  • Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
  • Select Quest Link.
  • Select Troubleshoot.
  • Review the metrics for each of the areas that could be causing your connection issues.

Additionally, it may be worth it to try connecting directly to your internet modem or router with an ethernet cable.


We hope these suggestions are helpful. Try these options and let us know if this solves the issue or not. We're looking forward to your response and hope to hear from you soon!



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey again @Celestin6669! We're following up to see if any of the suggestions we gave above were helpful! If you find that you need further assistance, please don't hesitate to reach back out to us! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


What version does your PC "Meta Quest Link" app say it's on? I had a similar issue and had to make sure it was set to BETA with version for it to work. Otherwise it would disconnect and fail. At least that's how it was with the link cable for me.

all checks are green

Meta Quest Link App Version
i dont use link cable, im on air link


Try turning on Public Test Channel, Settings-> BETA, then click it to blue and let it update. That did it for me. It might be a similar connectivity glitch. worked perfectly for me. Took me 2 hours of uninstalling it and blasting it off the registry with IObit Uninstaller and then reinstalling twice before I figured it out with help.

steamvr now start normaly, but airlink still disconnects after some time, like rn it disconnected me after 1minute into pavlov vr, but i was playing for like 40 mins before updating to beta and on old steamvr patch, before it disconnected me from airlink

We understand there was still a disconnect with Air Link after a while. We certainly want to get you back to gaming in VR with no interruptions and see that it has worked previously. With this already working, there are some details that can help us investigate further. Please reply back with the information below.

  1. Have there been any changes to the network since it was working? (i.e., name change, new password, new device, new router, new service provider, or new modem)
  2. Is the router in the same room as the headset?
  3. Is a VPN being used?
  4. Sometimes it can be resolved by repairing the Air Link.

We look forward to hearing back, and have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?