Showing results for 
Search instead for 
Did you mean: 

Quest 2 Airlink Freezing

Honored Guest

so i have an oculus quest 2 64gb and a legion 5 laptop ryzen 7 5800h rtx 3070 16gb ram


airlink worked perfectly fine before literally no problems whatsoever no lag no cut off, i decided to purchase a dedicated router for airlink since my other devices experienced slowdown when i was using airlink


i purchased an ax20 (ax1800) router, that's when the problem started, i would load up airlink as usual, all was working perfectly fine then suddenly it would freeze at my current point of view and moving would show black around it, on the pc side oculus mirror showed full movement and sound and hand tracking so the connection was still there.


i switched back to my vodafone router and the problem was still there, checked software and could see a fresh update to v31 (day before was v30) now i know there are problems with the ax20 in some cases on wifi 6 so i switched to wifi 5 and the problem was still there, even going back to the vodafone router (which i had been using for months with no issues) and disconnecting the ax20 entirely still caused the same problem. now were on v33 and the problem still exists


i tried these as a fix


factory reset quest 2

reinstall oculus software (and try public beta)

change bit rate (tried both dynamic and fixed at various rates)

reset both routers

disconnect ax20 router entirely and reverted to original setup

disable all wifi/bluetooth devices in the vicinity leaving just the laptop ethernet and the quest 2 

turn off game mode

change quest 2 device settings (resolution and refresh rate)

changed ethernet cable

tried just wifi on laptop side

disable igpu (both windows and bios level)

wipe igpu drivers just incase

disable hybrid mode (basically render the igpu non existent)

added firewall exceptions (already there)

disable firewall & antivirus

changed process prioritys

change wifi modes/bands/channels/names (basically all i could change)

roll back windows to a previous day backup

update drivers/downgrade drivers


the only fix that seems to work regardless of driver version is to reinstall nvidia drivers (i have tested this on 10 drivers) this works and the problem is fully rectified but a simple sleep/shutdown/restart and the problems come back to be fixed again by nvidia driver reinstall


the only thing i have not tried is using a link cable (currently do not own) a fresh reinstall of windows but that to me would be absurd as i had not altered windows in anyway and no windows update had taken place (i checked logs) from the day prior to the day the problems started, the only change was the quest 2 updating to v31 on the day the problem started, this coupled with other reports leads me to believe this would be a problem on oculus's side of things




Honored Guest

I am literally on the same boat as you, 

I hope you figured something about the issue,

I will try to change the NVIDIA settings in the hope it fixes something