Showing results for 
Search instead for 
Did you mean: 

Quest 2 PCVR stutter (Alyx/Boneworks) (Link cable, AirLink, VirtualDesktop)


The problem:


Roughly every 1-2 seconds, there's a small judder/stutter in PCVR games when moving. It's almost like a previous frame is rendered again. It is very noticable in alyx and boneworks using the joystick to move left/right and looking at a static object. I assume people playing with other movement types wont notice it easily.

It does not show:

  • On steamvr frame graph
  • On any of the oculus debug tool performance overlays, performance is rock solid on all graphs.
  • On the desktop window fro boneworks/alyx
  • On the steamvr vr view

Only shows in headset.


It occurs:

  • In alyx using steamvr
  • In boneworks using steamvr
  • In boneworks from the oculus store

I have tried two PC's:


  • Intel i7 8700K
  • 16 GB 3000mhz CL14 RAM
  • Nvidia GTX 1080


  • AMD Ryzen 5800x
  • 32 GB 3600mhz CL16 RAM
  • Nvidia RTX 3070

Most testing has been done on PC#2, but the experience is exactly the same.


What I have tried:

  • Official link cable, airlink and virtual desktop
  • Factory reset headset
  • Fresh windows install with only oculus client and steamvr installed, nothing else at all
  • Disable game mode
  • Turn off super sampling in steamvr (pretty much all combinations of steamvr/oculus settings)
  • Turn off ASW in oculus debug tool
  • Turn down all settings in game and run at lowest resolution in both oculus and steamvr. This in turn ran alyx with a frametime of about 1 ms.
  • Raised priority of all combinations of involed processes (oculus server, vrserver, the game etc.)
  • Used all combinations of the common alyx launch options.
  • Disable game mode in windows
  • Set the CPU/GPU profile to level 4 via. sidequest.
  • 72hz, 80hz, 90hz, 120hz (vd)
  • More stuff I forgot probably


  • I get 2.5 gbps on the USB test
  • There is no delay using airlink or vd. VD shows no network latency spikes. I run 2.5 gbps LAN to a wifi 6 router.
  • Nvidia drivers are the newest.

I have read countless of topics complaining about steamvr/alyx/boneworks stuttering.


My first thought is:


It might be the nvidia driver thing:


However it seems like it should be solved unless you run GPU monitoring software, which a fresh windows install obvously doesn't have. Odds are that this might not be the case, but everyone with new nvidia drivers should experience it, and some people claim to have a completely smooth pcvr alyx/boneworks experience? Are they just not using smooth locomotion and not noticing it?


My second thought is:


My headset is either broken or the stutter is a software error, either with the oculus compositor/encoder or the decoder on the headset. Again here, other people should experience it.


Third thought:


It's just a general thing with quest 2 and people just don't notice it? I experience no issues at all with native headset games.


I have only had the quest 2 for a couple of months and while I've enjoyed native games (mostly beatsaber), it has been a huge dissappointment having so many issues with PCVR.


Anyone have any advice at all? I'm about at that point where I consider returning it as defective.


If you want to test it, just boot up alyx or boneworks, look at a static object fairly close to you and move left to right to left continuously (smooth locomotion). You should see a small stutter every once in a while.



Had the same issue with my PC. Running a EVGA RTX 3070 ultra. Both Half life Alyx, and Boneworks micro stutter.. using Quest 2 with link cable,Air link and VD.. thought maybe it was my RIG, so I purchased a Alienware M17 R4 with RTX 3070... guess what all games still stutter! Tried 2 different Quest 2 headsets, and about 3 link cables.. all stutter... I returned the Laptop back to Bestbuy... I have now giving up on trying to play PCVR. Tried about ever settings known to man..... nothing worked, and I dug deep on the web... what a waist of time! 

Not applicable

same exact issue, tried same exact solutions, nothing... I'm just going to retire from VR for a few months until more oculus software and nvidia driver updates get rolled out, maybe it will get fixec (it's clearly a software issue on their part)

Honored Guest

Same problem. Did you try with a different headset to see if it’s related with quest/oculus?

Honored Guest

Having the exact same problem on my quest 2, it only happens with steamvr tho, games on the oculus library are fine. Happening with both VD and air link.

I don't have a different headset to test sadly. The problem is pretty widespread though, so it being a hardware error seems unlikely.


Still an issue with the new Nvidia 470 drivers.


When running Air Link and/or VD, are you connecting an Ethernet cable to your PC from your Modem? If not, I recommend doing so. That will help improve performance, especially with the more graphically demanding games.

2.5 gbps cat6 to my 8x8 wifi 6 router. Also that's obviously not the issue when it happens with the official link cable as well.

@kkthxbye1 wrote:

2.5 gbps cat6 to my 8x8 wifi 6 router. Also that's obviously not the issue when it happens with the official link cable as well.

Yes, but the official link cable has been known to have issues itself. If you are using the official cable and were also using pure Wifi for AirLink/VD instead of Ethernet, then the solutions would have been more straight forward: Buy a better cable and use an Ethernet Cable.


I would still recommend you get a better cable, since it is known that the official cable has issues. Although at this point, it does sound like the problem is related more to your own machine.

I use my Alienware laptop with Quest 2 and SteamVR successfully quite regularly. So this is likely not an issue with the headset.