Showing results for 
Search instead for 
Did you mean: 

Quest 2 PCVR stutter (Alyx/Boneworks) (Link cable, AirLink, VirtualDesktop)


The problem:


Roughly every 1-2 seconds, there's a small judder/stutter in PCVR games when moving. It's almost like a previous frame is rendered again. It is very noticable in alyx and boneworks using the joystick to move left/right and looking at a static object. I assume people playing with other movement types wont notice it easily.

It does not show:

  • On steamvr frame graph
  • On any of the oculus debug tool performance overlays, performance is rock solid on all graphs.
  • On the desktop window fro boneworks/alyx
  • On the steamvr vr view

Only shows in headset.


It occurs:

  • In alyx using steamvr
  • In boneworks using steamvr
  • In boneworks from the oculus store

I have tried two PC's:


  • Intel i7 8700K
  • 16 GB 3000mhz CL14 RAM
  • Nvidia GTX 1080


  • AMD Ryzen 5800x
  • 32 GB 3600mhz CL16 RAM
  • Nvidia RTX 3070

Most testing has been done on PC#2, but the experience is exactly the same.


What I have tried:

  • Official link cable, airlink and virtual desktop
  • Factory reset headset
  • Fresh windows install with only oculus client and steamvr installed, nothing else at all
  • Disable game mode
  • Turn off super sampling in steamvr (pretty much all combinations of steamvr/oculus settings)
  • Turn off ASW in oculus debug tool
  • Turn down all settings in game and run at lowest resolution in both oculus and steamvr. This in turn ran alyx with a frametime of about 1 ms.
  • Raised priority of all combinations of involed processes (oculus server, vrserver, the game etc.)
  • Used all combinations of the common alyx launch options.
  • Disable game mode in windows
  • Set the CPU/GPU profile to level 4 via. sidequest.
  • 72hz, 80hz, 90hz, 120hz (vd)
  • More stuff I forgot probably


  • I get 2.5 gbps on the USB test
  • There is no delay using airlink or vd. VD shows no network latency spikes. I run 2.5 gbps LAN to a wifi 6 router.
  • Nvidia drivers are the newest.

I have read countless of topics complaining about steamvr/alyx/boneworks stuttering.


My first thought is:


It might be the nvidia driver thing:


However it seems like it should be solved unless you run GPU monitoring software, which a fresh windows install obvously doesn't have. Odds are that this might not be the case, but everyone with new nvidia drivers should experience it, and some people claim to have a completely smooth pcvr alyx/boneworks experience? Are they just not using smooth locomotion and not noticing it?


My second thought is:


My headset is either broken or the stutter is a software error, either with the oculus compositor/encoder or the decoder on the headset. Again here, other people should experience it.


Third thought:


It's just a general thing with quest 2 and people just don't notice it? I experience no issues at all with native headset games.


I have only had the quest 2 for a couple of months and while I've enjoyed native games (mostly beatsaber), it has been a huge dissappointment having so many issues with PCVR.


Anyone have any advice at all? I'm about at that point where I consider returning it as defective.


If you want to test it, just boot up alyx or boneworks, look at a static object fairly close to you and move left to right to left continuously (smooth locomotion). You should see a small stutter every once in a while.



Check your problem with other hardware. Stutter problems are old problems. this problem have many solutions. change your router and change your pc in your network. testing your hardware in another 5Ghz/Wifi6/Gigabit LAN network. i'm also testing cloud pc gaming (PlutoSphere Beta) with nvidia graphics. Also there no problems with alyx and boneworks. Oculus cannot test every combination of hardware. you have to do that yourself! I used recommended hardware and with it the fewest problems. Many problems lie in a bad driver connection or faulty BIOS versions for graphics and mainboards. sorry for my direct statement on this subject, but i have been testing VR hardware for a long time.Unfortunately, the most expensive hardware is not always the best hardware. Rely on products that have been tested. Find out more in discord and reddit, because others have your problems too. The best solutions are offered there.


You really have not read a word i wrote, first of all this is not a stutter, this is more something like a dropped frame or frameskip unrelated to performance as it does not show on performance metrics. i have already tested different hardware, i have already upgraded BIOS and as i already mentioned, tried different Hardware and network combinations, and as i already explained, this is either a faulty HMD, or GPU, sorry for my direct statement, but no, this is not a common issue, this post right here is one of the few mentioning something similar to my experience. read my posts and the main post here again, this is not something exclusive to Air Link/VD, it happens using wired Link aswell, with different cables, different ports and different motherboards. 

I'm actually beginning to think some people just don't notice small stutters.


@andrew.tadstone - Please don't reply in the post unless you have read my original post and understood it. You keep saying stuff that's in the top post.


Everything is said now. I guess that's why the support won't be able to answer you directly and solve your problem. I don't think you will be offered any other suggested solutions. Speaking of frame drops, it also causes stuttering. I have several PCs (AMD / Intel) and 2 Quest to test (v34 / V35) and both do not show your problems. The best thing to do is to open a ticket and hope for a better answer. I'm out of here.

yeah this guy is trying so hard to defend Oculus/Meta without comprehending the issue at hand, he still thinks it is a stutter, im guessing you still have this issue. this post is the first one which actually mentions the exact same issue ive been having since nov 2020.

just to confirm, does the judder you experience look like this example, but for approximately one frame? very noticeable while strafing and looking at static objects, or using smooth rotation,



Sorry I'm not defending Oculus / Meta. I have no business relationship with Meta. I'm just telling the truth that oculus cannot test every hardware / software combination and that you are responsible for your own technical environment. various communities are full of solutions for your technical problems. A little more work in hardware testing and extensive research has not harmed any VR user. A PC is not a console and the differences in configuration are huge and can create problems for you. If there is a technical hardware defect, you have enough options to solve it. I really am out.

You are really not saying anything of substance here besides repeating yourself with the same useless information, we know this, and this is why we are having this discussion where we are doing extensive testing, please don´t respond anymore unless you actually have something useful to say besides repeating that everything works fine for you.

Actually this is exactly what I am seeing as well in Alyx, specifically on VD. Airlink doesn't have that.

I experience that exact judder, even though performance metrics all look good - latency is at 40ish, getting 90fps or so, no lag no nothing, just that specific judder.

3900x, 3080, 32gb ram. PC is connected to router by cable, and headset to a dedicated 5ghz AP.


Yeah Alyx was the first game i noticed which displayed this behavior, no matter the settings, wired or wireless, either people don´t notice, or this is something that ocurrs only for some people. might be our HMD.