Showing results for 
Search instead for 
Did you mean: 

Quest 2 not connecting via Air Link after removing it from the PC app.

I have used AirLink many times before. Today it was not working probally because of the wifi, as I have been having some problems with my wifi recently. So, I removed the Quest from the devices in the PC app. Now, the Quest won't add to the PC app even after diabling AirLink, restarting, and re-enabling AirLink on the Quest. Any help would be much appriciated! Is it because I have already used AirLink before so it is not starting the setup process? Would like to avoid a factory reset if possible.


Community Manager
Community Manager

Hey there! We know this can be quite frustrating, and we want to help you out and get to the bottom of this issue. If you could please go ahead and repair the Oculus app on your PC. We know that performing a factory reset isn't ideal, but if repairing the app doesn't work, please try and perform a factory reset. Thanks! We hope you find this information helpful.

Thank you so much for the speedy reply! After a couple of hours, I tried connecting it again and it worked fine. Thank your for your help though!

Hey @Penguin_Terminal that's great news! We're happy you were able to get that connection back up and running! Please reach out if you need any other assistance.