Showing results for 
Search instead for 
Did you mean: 

Quest 2 not fully charging since 39.0 firmware update

Level 4

So, I have recently discovered a huge potential problem. I started to notice that my Quest 2 won't charge - even though it would show that it's charging both by LED and the battery icon.


After using the Link, I always sit the Quest 2 down and power it off (holding the PWR button), still attached to my PC. The LED showed orange all the time, so I didn't look into it and thought that all is well. Then, I started to notice that my Quest 2 is not at 100% after picking it up to play the next day. Moreover, it appeared stuck on the same percentage that it was the day before.


So I started to dig into this:

1. Official Link cable + laptop = not charging (orange LED, stuck at the same %)

2. Official Link cable + Quest 2 charger = not charging (orange LED, stuck at the same %)

3. Asus USB-C laptop charger = not charging (orange LED, stuck at the same %)


After some Googling, I have tried to charge the Quest 2 in the DFU mode (PWR + volume down). I enabled it and sit the Quest 2 down. 'Lo and started charging. But only in DFU. The charge stopped after I turned the headset on or off.


I've downloaded USBDeview - this program lets you see all USB devices connected, USB protocols and speeds they're running at - and most importantly, the amperage going to the devices.

When the headset is off - it took 0 mA. Sitting at 53%.

When the headset is in DFU - it took 128 mA. Not much, but we take those - and it's enough to charge it very slowly. 


After some cross-referencing, I nailed it down to the 39.0 update. Something is majorly screwed.


Some other interesting findings:

1. Sometimes, Quest 2 is actually charging. But never to 100%. I've noticed that it sometimes jumps from 53% that I left it at to 72% and is stuck there

2. The percentage sometimes would show 100% when powered off after being connected to the charging cable - but the battery icon would show the correct 2/4 bars  - because in reality when powered on, the Quest 2 would show me something like 56-57% battery

3. The only way to charge to 100% is the DFU mode.


I cannot stress this enough, the headset is NOT physically faulty. It used to charge just fine before the 39.0 update.

And it still does so. But only in the DFU mode.

That points me towards a software issue.



PC: Asus ROG Zephyrus G15 (2021). 5900HS / 3080 / Windows 10
Headset: Oculus Quest 2 with Link
Software: 41.0 PC, 40.0 Quest 2
105 REPLIES 105

Level 3

I'm having the exact same issue with the exact same symptoms sometime after I updated to v39. Conversations with Oculus Support lead to them recommend a hard reset, which didn't work. They are now requesting me to return the unit to them but I'm not based in th US so I can't at the moment. 


I currently also charge in DFU mode but I am concerned since the backlight is running in DFU mode and there's a bit of heat. 


Hoping the next software update sorts it out, else I'll need to figure out the logistics to return it. 

Level 15

@Fatalution  I've found that it sometimes depends on your PC's usb3 ports.  My z390 motherboard ports seem to continue to supply charging power after powering down both my Q2 and PC but my pcie usb3.1 sata powered ports do not.  In any case, if you want to properly recharge your Q2 you should simply use the supplied Q2 charger/cable imho.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro

Level 3

I am having a similar issue as well. I been debugging it and as @Fatalution experienced, the temporarily fix for now is charging whilst in the DFU menu, but this is far from a proper solution. This has happened extremely rarely before V39 but it's now impossible to charge at all. In a booted up mode, or turned off. It displays the charging indicator (UI/physical LED) but with the help of an external USB ammeter it's clearly not drawing any current at all. Even leaving it connected to a power source for hours doesn't do anything in either of those states.  


I am fairly certain as well there is no issues with the hardware side, seeing as it's able to charge fine in DFU mode. Sadly, there's no way to undo the update, so I really do hope this issue is addressed. 

I have tried all the following chargers:
>Official Quest 2 Adapter
>Dell USB C PD Laptop Adapter
>Samsung 5V 2.4A USB Adapter
>Samsung QC 3.0 USB Adapter


A particularly big issue as well is I have noticed that the issue also occurs with powerbanks, so despite having one connected the Quest 2 will still drain and run out of juice as it can't charge from the powerbank!

My only lead at this point is maybe a software temperature threshold set too low is causing this, if so the limit is set too low as the headset quickly heats up in use anyway.

As I've mentioned in my post, I have tried my PC, my laptop, official Quest 2, and Asus chargers. None of them work properly outside of DFU - and it only started after 39.0

PC: Asus ROG Zephyrus G15 (2021). 5900HS / 3080 / Windows 10
Headset: Oculus Quest 2 with Link
Software: 41.0 PC, 40.0 Quest 2

The temp limit being borked is one of the things I suspect as well. It seems like the cause of this issue, actually. They could have screwed the number up between updates, which is totally possible 

PC: Asus ROG Zephyrus G15 (2021). 5900HS / 3080 / Windows 10
Headset: Oculus Quest 2 with Link
Software: 41.0 PC, 40.0 Quest 2

Level 2

I have the same issue with our 2 Quest 2 devices.


One of our Quest 2 received the update. The next time we used it we noticed it wasn't fully charged despite being plugged in all night. We initially thought maybe it just wasn't plugged in correctly but it has not been able to charge since the update.


A few days later, our 2nd Quest 2 got the update. Now neither of them will charge.


We are using the original chargers and cables that come with the Quest 2.


When plugged in, the lights on both go orange, but no charging is actually happening.

If you power them on, the battery icon has the little lightening bolt on it, indicating that it knows it is plugged in and thinks it is charging, but no charging is happening.


I did try charging them DFU mode as mentioned in the original post, and this does work for both.

Pretty obvious this is a software issue with the update and not a hardware problem.


Level 3

Bad news, my quest got updated to v40 and it's still doing the same thing. May attempt a factory reset again. 

I am on v40 also and did a full factory reset and nothing has changed. Mine always stops at 53% and won't get any further unless I charge in DFU mode.

Level 3

I would also like to add that I've run into this issue myself recently. Only charges in DFU and factory resets had no effect. Really hope this is addressed soon.