Showing results for 
Search instead for 
Did you mean: 

Quest 3/ Air Link stopped working/ No connection to PC/ PC found but Start Button is greyed out...


I've been using the Quest 3 for almost 8 months now, and before i used the Quest 2 without any problems via Air link/same router/same PC...

This Saturday I'm playing Borderland 2 VR and on Monday the Quest 3 can no longer connect to the PC without any reason.

If I want to activate Air Link via the Q3, my PC is displayed in the Air Link Menü as before, but the Start Button for Air Link remains gray and it says "not connected".

I've already tried everything:Hard reseting the Headset, factory reset, router reset, PC & Quest 3 reset, Meta Quest Link restart via the beta menu in the PC Oculus APP, repair function of the Meta Quest APP, firewall completely switched off but nothing...

Then I read that you should completely delete the Oculus software with all folders and reinstall it.
I did that and lo and behold it worked, for exactly ONE day....

When I booted up my PC today and started Quest 3, the same problem...
The PC is displayed but the start button to start Air Link remains gray and it is not connected.
Do I have to completely uninstall the software every time, including all folders, then reinstall it in order to be able to play via Air link for exactly ONE day, which has worked for over 3 years before (Quest 1, Quest 2, Quest 3) without any problems?

The connection works immediately using the original Meta Quest Link cable.
Virtual Desktop APP works also...


198 REPLIES 198

This workaround got me going again, if not permanently.
I hadn't seen this post earlier, so I thought I point it out for other's benefit.

Honored Guest

Mine was working an hour ago when I was playing VTOL VR. Then I take a break for an hour while my buddy got food and went to jump on again just to find out that out of nowhere and for no reason it won't connect no matter what I do. Restart computer, restart headset, double checking drivers, turning air link off and on. 

Should've just paid the money for an index or something instead of this facebook garbage. 

LOL ...
lets not get carried away.
I had far more issues with my Index than i have ever had with either of my Quests and throwing a dummy wont achieve anything. Steam Connect works just fine which is free as does virtual Desktop if you own that or even use a cable so your not dead in the water .. It will get sorted soon enough 🙂

Additionally, although the workaround is inconvenient, it remains a viable option. I'm confident this issue will eventually be resolved. However, the frustration stems from the fact that everything was functioning perfectly before the recent updates caused these problems. If it wasn't working well initially and then broke, it would be more understandable. But to go from working perfectly to not at all feels like a move Microsoft would make.

Hello LaserDisk,

I experience the same problem.

Your tip is working, thank you.

The quality is low with Air Link !


I understand the frustration you're experiencing with your Meta Quest 2 and Air Link. Based on your description, it seems like you've tried a comprehensive set of troubleshooting steps. While a permanent fix might be pending an update from Meta, there are some temporary workaround solutions discussed in the current forum topic that might help alleviate the issue in the meantime.

I highly recommend reading through the recent messages in this forum thread, as they contain several workaround fixes that users have found helpful. These temporary solutions might provide some relief until a more permanent fix is available.

Thank you for your patience and understanding. I hope you find the shared workarounds beneficial.

Honored Guest

I have had an oculus quest 2 for about 2 years and every time I have a problem with air link. Once when I got oculus there was no air link and I played free games. After a while they added airlink and it worked but after about 2 months it wouldn't connect and I decided I didn't want to fix it because I didn't have time for it. After a while it connects and works perfectly and then it stopped working again and I gave up again. I remembered that I got an oculus 5 days ago and I wanted to play with air link. It worked I was happy and I played with a friend but today it wakes up and doesn't work again. It detects my computer but when I click pair it doesn't give any code or anything and the word pair simply changes to launch which I can't click and nothing shows up on the computer.

Greetings @JakubElend 

Thanks for telling us, I’m going to ask you these questions.

1. Do you have a good Wi-Fi connection?

2. Did you restart everything?

3. Did you contact Meta?

4. Did you delete the app from the computer- PC and install it back in?

With you have any questions, contact Meta.

1 I have ethernet cable
2 yes
3 yes but they dont help me

4 yes I reinstall windows and app

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?