cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 3/ Air Link stopped working/ No connection to PC/ PC found but Start Button is greyed out...

Playsianer
Protege

I've been using the Quest 3 for almost 8 months now, and before i used the Quest 2 without any problems via Air link/same router/same PC...


This Saturday I'm playing Borderland 2 VR and on Monday the Quest 3 can no longer connect to the PC without any reason.


If I want to activate Air Link via the Q3, my PC is displayed in the Air Link Menü as before, but the Start Button for Air Link remains gray and it says "not connected".


I've already tried everything:Hard reseting the Headset, factory reset, router reset, PC & Quest 3 reset, Meta Quest Link restart via the beta menu in the PC Oculus APP, repair function of the Meta Quest APP, firewall completely switched off but nothing...


Then I read that you should completely delete the Oculus software with all folders and reinstall it.
I did that and lo and behold it worked, for exactly ONE day....


When I booted up my PC today and started Quest 3, the same problem...
The PC is displayed but the start button to start Air Link remains gray and it is not connected.
WHY?
Do I have to completely uninstall the software every time, including all folders, then reinstall it in order to be able to play via Air link for exactly ONE day, which has worked for over 3 years before (Quest 1, Quest 2, Quest 3) without any problems?


The connection works immediately using the original Meta Quest Link cable.
Virtual Desktop APP works also...


PLEASE Help!

198 REPLIES 198

Same problem many of us are having, see link below to recent thread in which Meta responded, but didn't really help.... In a nutshell, Meta broke something when they created the last patch (65), everyone makes mistakes, but this seems pretty careless. There's a process called regression testing Software Engineering teams have to go through where all core features should be tested prior to a patch going on.

It's clear Meta did not do this. It's sloppy product management and hopefully gets addressed internally.

Until then, your PC VR library, at least through Meta's store is useless. You will find Steam Link unaffected. 

https://communityforums.atmeta.com/t5/Get-Help/Quest-3-Air-Link-stopped-working-No-connection-to-PC-...

 

vracing73
Explorer

Add me to the list.  Just happened today using version 65.  To get to the point, the pairing setting does not get saved.  I have to pair my Quest 3 every single time after I turned off and on of my headset.  Paring my Quest 3 every single time after a complete shut off? The pairing information does not get saved.  

itamar_bl
Honored Guest

I honestly don't know what to do everything was fine and 4 days ago my q3 just won't connect to my PC and shows a location icon on the list inside my headset I tried everything

1) I tried to reset the PC and the q3 with no luck

2) I deleted the device from the device list in the PC app but it did nothing

3) I uninstalled the PC app and when I tried to reinstall it it wrote me: "Sorry we encountered an error during inspiration please restart your computer and try running meta quest link setup again."

4) After realizing that restarting my PC is not working I went to the log file(shows what went wrong with the installation) and I found out that the problem was it can't install the oculus-driver.exe file so I tried to download the app again but this time while the app was installing I placed the driver file that I installed separately inside the support file and it installed the app but a new problem showed up when I tried to pair the q3 I pressed the pair button and it turned into a grey lunch button with nothing happening

5) I installed the oculus-adb-driver-2.0 from the oculus website and I installed it and it wrote the operation was successful and I could pair the q3 but a new problem showed up in the device list when I connected my q3 it showed a red x and a message saying "no headset audio" and inside the quest 3 it shows the 3 dots loading screen

6) I did a factory reset to my q3 with no success

7)I uninstalled and reinstalled everything with the methods above and the "no headset audio" problem was gone but the 3 dots stayed

So now i have no idea what to do PLS HELPP!!! 🙏

no headset audiono headset audiothis is  from nowthis is from nowa6c34f3d-b2e7-4e17-a8df-4f43405c9337.jpgthe location iconthe location icon

PLS HELPPPP!!!!!!!😭🙏 i really want to try the new blade and sorcery update

Hi,

been having this problem for about 8 days, my details are:

Headset Version: 65.00.546.341.596219110 / Runtime: 65.00.548.344.596219384

PC App Version: 65.0.0.499.343

Headset = Quest 3

Not on PTC for Headset or PC App.

Yeah same issue, was connected then it stopped working. Did your update and nothing has changed. I'm a developer and need it for testing, using the cable is unreliable with your desktop app for some reason,
never have connection issues with Virtual Desktop or side quest, but my project is for the quest and is on your store so I need oculus to run. It's actually quicker now to build my project, connect with sidequest and upload it to test than get it connected with your app. This is crazy.
This should be the one thing your desktop app does well, how can virtual desktop get it to work flawlessly and your app can't even do it. 
Are you fixing it? it's been 2 days now for me, costing me time and money.

Yep same issue here. I am on the PTC, so on System version 50875380064600150 Runtime 66.0.0370.60899713

AirLink stopped connecting and I have to follow the workaround  and disable/re-enable and Pair again each and every time.  Major pain.  Not sure if it is related or not but

1. Often the MetaQuest LINK screen doesn't open by default and I have to force it in order to do the Pairing

2. Performance (when it is working) seems to have drastically decreased as well including frequent disconnects.

Been using this successfully (with hiccups as things break with new releases) for YEARS so this isn't Operator Error, this is a broken firmware.

 

Uviox
Honored Guest

So I know this issue is going around but is anyone else having the issue where Airlink isn't working at all, Virtual Desktop says 'Computer is unreachable' and Steam tells me my headset and pc aren't on the same network. So I'd HAVE to be tethered to use pcvr now... 

All I can say is check your network connection on the Headset. I have  2.4 GHz and 5 GHz networks on my dual band router and every so often the headset decides to switch to the 2.4 GHz network instead of the 5G.  STEAMLINK warns me that it is not enough bandwidth and I can go in to change it. Then things work OK (except for the current AIRLINK issues). 

My PC is wired into the Router so I guess both networks are accessible to it. Maybe your headset is randomly connecting to some other network if there is some open WiFi within range.

Uviox
Honored Guest

Its the only accessible wifi network at all, and within the headset I'm on the 5ghz network same as on my pc. This sucks considering it worked fine two nights ago and now im banging my head against a wall. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?