Showing results for 
Search instead for 
Did you mean: 

Quest 3 & Pro controllers stuck at 0% updating


0% update forever on both PRO controllers that are already sync with a quest 3 headset

What I had done..

Pair them again and again the Q3 got them paired all the time
Hard reset on controllers
Factory reset on Q3 headset (even that involves a huge waste of time)

V64 is the version of the software of my Q3
Nothing worked so far in other post I saw that randomly people finally got this controllers working what was not my situation

Support on chat after we try it everything  ask me to send the pro controllers back what I already did  (I already did all that support was asking for but for respect the support guy time I follow all what he asked for "maybe it works this time by a chance").
As I see this issue as very common I want to know what is going on for PRO controllers, Q3 is perfect for me for work as I use them as tool, but for play even vs Q2 the tracking of quest3 is inferior by a lot.

If there is no proper solution for this I see no point in order another controllers or even keep the quest 3.


If as an update you mean V64 I already have V64 installed, btw is not and old issue as I I know and  have found over internet this issue has been on existence and  unfixed since quest2, same issues reported a year ago.

I guess they're talking about all the new versions that came out in the last year. I tried it now with v63, v64 and even with the public test channel version v65, with multiple resets and new pairings... I guess I'll just send back the headset and the controllers, this is ridiculous considering the price tag.

Honored Guest

have the same issue with my right controller for quest 3
its stuck 33% when update, and the failed
now my controller is blink SOS

Honored Guest

I'm facing the same problem, my left controller freezes at 66%. I have already tried all the methods that were on the forum, nothing helped. And what should I do?😥 

Honored Guest

Are we potentially just waiting for a new firmware update in order to fix this issue? As others have stated, I’ve tried every technical support help tip multiple times on my own and through meta support. I’m still looking at the left and right pro controller unable to get past 0% on the update. 

Honored Guest
I received my Quest Pro controllers yesterday and I'm having the same problem, I've spent more than 8 hours trying to fix the problem, but I can't get it to update.
I've done all the steps that have been mentioned in the forums about this topic:
  • Controller Factory reset.
  • Un pair and pair again (more thatn 20 tiemes)
  • Update de phone app, and try again. 
  • I've left it all night doing the update without succes

I have tried to pair it with my old quest 2 to see if I could do it and it doesn't do the update.


Thanks for any help you can give me.



The problem was solved in the latest update of the Quest 3.
This version was not made available until I wanted to open a bug report from the glasses themselves.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?