Showing results for 
Search instead for 
Did you mean: 

Quest Link makes continuous connecting/disconnecting noise With Quest 3 On v66 PTC

Honored Guest

Hi, so quest link isnt working since i updated to v66 ptc. And i cant go back to v65, i turned off the ptc and factory reset multiple times but no. Its just stuck on v66. When i connect my link cable to my PC it sometimes doesnt connect, and when it does, it just rapidly connects and disconnects with windows plug in-out sound. But it doesnt stop charging. I tried it with multiple cables and PCs, none of them worked. And i dont think there is something wrong with my Quest 3 because im taking good care of it and and im not using it often. Idk what to do, i need some help.


Headset version


Link app version ( i tried with v66 too but it didnt work, i could just easily quit from ptc on PC)



Retired Support

Hey @viyuuu! I noticed that you are trying to run back to the v65 live build. I know that the v66 live build is starting pushing out this week (Meta Quest release notes), so that could be why you're unable to rollback as your headset could be using the v66 live build. Live builds are a bit more stable than the PTC versions. 

As for your issue with Quest link disconnecting you, are you having the same issue with Air Link as well? Can you also let me know if you tried troubleshooting the Oculus PC app? Since your already Factory reset the headset, I wanna see if we can isolate any problems from the PC app's end.

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

I've been trying to rollback to v65 for like two weeks. I wasnt able to rollback even before the v66 live build. And Air Link is working fine, i checked it. And i fully reinstalled windows and everything on my laptop. It didnt work and i think theres nothing left i can do about Oculus PC App.

Thank you so much for that information! I'm wondering if the able is the issue. Have you tried another link cable yet? Do you know anyone else who uses the Quest headsets might have one you can borrow to test out?

I would say for now, just keep the PTC toggle off, once v66 gets pushed to all headsets, we can be sure you're out of the PTC version.

Let me know if the new link cable addresses this issue, I'll be here ready to assist you further!

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

Hey again, just checking in. Whenever you can, please feel free to reply back. Thank you!

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

Sorry for the late reply, thanks for your answer. The issue is still not resolved. I tried different PCs and cables, none of them worked. I think i'll wait for the full release. Maybe then it will get fixed.

No worries, just let me know. I'll reply as soon as possible for when you provide that update! 🙂

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

Honored Guest

I have also had the same problem since v66 rolled out.  My pc disconnects  all the time. Sometimes sooner, sometimes later. I get two kind of error message: General device problem and usb connection problem. And I am advised to use usb 3 port instead of usb 2. But I have always used usb 3 for my Quest 3. I changed the ports and modified energy saving option of the ports to hinder them from turning off. But no avail. The problem still persists. 

Honored Guest

I'm having the same issue across 2 Quest 3's that both got updated to V66. I even tried 2 different USB-C cables between the two units and both were exhibiting the same problem. I plug in the device and immediately the pc will keep disconnecting and reconnecting the USB until it faults with a general device error on the Meta Pc app. Both Headsets worked via pclink in previous updates. 

Hi there, @Zsozsa and @klondorthedestroyer! Making sure you have a seamless PCVR experience is a top priority for us, so thank you both for letting us know what's been happening! To be absolutely sure we narrow down all possible causes, we'd like you to try opting out of the Public Test Channel (PTC). Depending on how you enrolled, you can follow the steps in this article to opt out using your mobile app or here to do so on your PC:


  1. Open the Meta Quest PC app on your computer.
  2. Select Settings in the left menu.
  3. Select the Beta tab.
  4. Next to 'Public Test Channel', click to opt out.
  5. Manually reboot the headset.
  6. Test the Quest Link connection with your Quest 3 headsets once more.


Please let us know if anything changes or if the same issue persists, as we're happy to help get to the bottom of this with you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?