Showing results for 
Search instead for 
Did you mean: 

Quest touch pro trigger mistakenly detecting touch


It detect to "touching" the trigger when my index finger just close to the trigger and not touch it.

When I push the trigger then leave, it don't leave immediately in unless I fully open my hand to keep my index finger really far away from trigger, it makes me hard to switch my gesture from fist/thumb to point/gun.

Is this caused by touch pro's index finger tracking?Can I turn this this feature off?I just want my trigger touch response works like quest2 controller works.

131 REPLIES 131

i have same issue too...

i bought my quest pro a week ago

and mine is worse-

trigger is detected even 2mm+ 

i followed your all hand tracking or disconnect and reconnect, but nothing changed

I really wanna know this is software problem or hardware problem...

Tried it and no use.

And I find the severity of misrecognition level could be different after restarting. Sometimes it's much more serious than the situation in my video but can turn better after restarting.

We appreciate you bringing this to our notice. We recognize that you continue to experience issues with your Quest Pro controllers. We are aware of the impact this has on your VR experience. We strongly suggest you performing a factory reset on the controllers, we'll leave the steps below for you to give it a try if you haven't done so yet. 


  1. Right Controller: Hold A and Oculus buttons until the LED begins flashing red/white.
    Left Controller: Hold X and Menu buttons until the LED begins flashing red/white.
  2. Release the buttons immediately after the LED begins blinking red/white.
  3. Perform a manual pairing and check if controller LED would flash blue and white to signal pairing state.
  4. Once paired, controllers may take a while to update and stay unresponsive until they finish, and LED would be purple during the update.

Please let us know how it goes so we can determine if any additional steps are required! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

i did, and for me, nothing changed

or become even worse i think

is the matter if steam vr's monitor saying that

my controllers are quest2's controllers?

it doesnt say quest2, but it look same as quest2

im feeling dizzy about this problem for real...

can i update to previous version of controller settings? i saw this matter appears after update

Hey @Cakioke! Thank you for that information. There's no way to revert back to a previous update. Our engineers are aware of this issue and are working to get it resolved. Thank you for being patient as we figure this out!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


I've also been having this same issue for months. It's awful. Sometimes I'm not even holding the controller, and it's still saying that my fingers are on the trigger when they aren't.

It's so annoying that I've debated going back to the original controllers, but then I'd lose tracking standing straight up or having my hands behind my back.

Feels like I wasted $400 honestly. At least I know I'm not the only one with these issues.

I've even tried doing like a DEEP clean of the controllers, because sometimes when your hands get sweaty or greasy, it detects you are touching buttons when you aren't.

I REALLY hope they fix this problem soon, because I'm tired of fighting with my controllers just to do basic finger movement expressions.

Hey guys. Having controller triggers not register touch correctly can really hinder your VR experience, so let's see what we can get done! 

If you haven't already, could you please attempt try to unpair and repair your controllers. 

If that doesn't work, could you also restart your controllers with the following:

  1. Hold down the Oculus button on the right controller, or the Hamburger button on the left controller
  2. Once you see the LED change or feel haptic feedback, it means the controller has restarted. You can now let go of the button and try pairing again.

If none of those seem to help out, we do recommend reaching out to us by clicking on our name and then clicking 'Send a message'. 

We'll see you on the other side!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


Already done this MULTIPLE times, and it was already suggested in the thread.

This is a controller issue, and it has something to do with the proximity sensor in the controller.

Again, to clarify, it's not an issue with the triggers, it's an issue that we are NOT TOUCHING the triggers, and they are still being detected as if we are touching them.

Hi there, @Livvydoodlez. Thanks for your reply and letting us know that you have completed those steps. We see that you have already taken a few troubleshooting steps; however, we would like to confirm that you have also done the following:


  • Removed the batteries and leave them out for 10 minutes to allow the firmware to reset.

If you have done this, can you answer these questions for us?


Are you experiencing this issue with both controllers?

Can you see any lights on your controller(s) that are on (blinking or solid)?

If possible, can you take a video of the controller issue?


Please let us know if you have any questions. We are looking forward to your response.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?