cancel
Showing results for 
Search instead for 
Did you mean: 

Quest touch pro trigger mistakenly detecting touch

a324260327
Protege

It detect to "touching" the trigger when my index finger just close to the trigger and not touch it.

When I push the trigger then leave, it don't leave immediately in unless I fully open my hand to keep my index finger really far away from trigger, it makes me hard to switch my gesture from fist/thumb to point/gun.

Is this caused by touch pro's index finger tracking?Can I turn this this feature off?I just want my trigger touch response works like quest2 controller works.

131 REPLIES 131

ThyRuinedKing
Meta Quest Support
Meta Quest Support

Hi everyone,

I wanted to address the recent replies and concerns you've expressed. First, I went ahead and made an edit to the post marked as an Accepted Solution. This is so any users experiencing this issue are aware to reach out to our two points of contact (@MetaQuestSupport or Support Ticket), which is needed so we could pass information along to our engineers.

As for the replacement controllers, there have been instances of users who receive replacements and no longer face this issue. Of course, this is not a permanent solution to all users, as updates for software will run into hiccups at random times. Since we cannot determine accurately what devices may have this issue, some replacements may continue to face this issue.

The reason we ask to reach out to our Support team is so we can gather as much information as possible for our engineers. They have specifically asked us to gather these details as they are actively looking into this issue. Unfortunately, we have not yet received an update from the team, so we haven't been able to reply with any other information beyond the previous messages of "our engineers are looking into this".

As soon as there's any information regarding an update to this issue, we will share it to everyone within the thread as soon as possible. I understand this can be frustrating, but we greatly appreciate all your patience while the engineers look into this.

In the time of your life, live - so that in that wondrous time you shall not add to the misery and sorrow of the world, but shall smile to the infinite delight and mystery of it.

P.S., I can beat you at One Piece TCG and Tekken

Thank you for updating the post and being honest.

I don't know if this will be helpful but I have two of the three boxes for the pro controller sets and both boxes say they were manufactured in September of 2022. I'm curious if other people who are having this issue had their controllers manufactured with the same date stamp or somewhere around that date. Maybe there was just a bad batch? Just a thought since both of my boxes have the same manufacturing date.

I'll reach back out to the support team and try to get my controllers replaced again.

The support team is useless. They are giving me information about quest 2 controllers, when the issue is about quest pro controllers.

Also, the RMA isn't working, idk where you see of people saying the issue is fixed with getting an RMA, but the people HERE in this thread who HAVE RMA'd their controllers, are still having the same issues.

I have a better idea, as already suggested, have the engineers LOOK AT THIS THREAD INSTEAD! Because we all have the same issues, the support team isn't helping, I've been asked to open the battery compartment of a quest pro controller twice now, and that's literally impossible.

I'm going to lose it if I RMA my controllers, not be able to be in VR for multiple days and then having to deal with the same issue again, as other people in this thread have dealt with.

Have the engineers look HERE, instead of sending US to the support team who clearly don't know what's even going on.


And again, unmark this thread as solved, because it's not solved. It's not an accepted solution. It's STILL a problem.

When were your controllers manufactured? It says it on the side of the box.

No longer have the box unfortunately, but I got them Apr 14th this year

I believe I may have found the problematic part of the controller that causes the issue. I believe the cause is the part of the controller that detects the slide and curl of your finger and trigger sensor being too sensitive. I bought another set of controllers so I still have a pair under warranty. I've circled what I believe to be the curl sensor in the photo linked below. 

I've noticed that when my finger gets stuck and I touch the side of the controller or sometimes get close enough, it will think that I am touching the trigger or it will register my finger moving along the trigger even though my finger isn't resting on the trigger itself. If this is the case, this issue could easily be resolved by lowering the sensitivity of the finger curl sensor and or adding a check so that the index finger sensor must be activated in order to register that a finger is resting on the trigger. That way the curl slider sensor cannot determine whether you are resting your finger on the trigger. 

However, I've also had moments where my hand has to be at least 5 inches away from the trigger sensor for it to register that I am not touching the trigger. Lastly, sometimes when lifting my finger off of the sensor, it will register correctly for a split second before sticking back down again which leads me to believe that there is a bug that keeps changing the sensitivity of BOTH the trigger touch sensor and the finger curl sensor.

 

Finger curl touch sensorFinger curl touch sensor

1TheBlueWii1
Explorer

Woah, I get the same results when I touch the side of the controllers. It curls when I press my finger on those spots. Nice find! I wonder if the warmth of my hands eventually makes those spots super sensitive to detecting a "touch"...

threewastaken
Explorer

sadly I had to promote my pro controllers to paperweights since it's way too much trouble to use them with that bug.but it's nice to see people trying to figure it out.

 

I own straps for those controllers, and I remember clearly as my finger got stuck letting them dangle from the strap (thus not touching them at all) and still have them thinking my index finger is touching the button.

1TheBlueWii1
Explorer

Sooo I learned something.

I was trying to figure out the trigger sensors and how it reacts to my hand. I even tried "occluding" the sensor with objects (like blankets, and even tape) but it seems to only react whenever I touched it with my skin.
...then the thought occured to me. I paired my Quest 2 Controllers to see if those worked the same way, and to my surprise, it does!
The sensors react to the electricity of our body. Same way a touch screen on a phone reacts to your bare fingers, but not when you have gloves on.

Given that fact, I may know the culprit of the Pro Controller's problems...
It's the magnets inside. There are magnets that keep the controllers together when you place them on the charging dock.
I have another issue with the Pro Controllers where the thumb rest would be "touched" but not have my thumbs on it. However this can be fixed by rebooting the controllers (Hold the Home/Menu buttons for 10 seconds), but the problem comes back whenever I take them off the charging dock.

Here's a video demonstrating the triggers reacting to the magnets of the opposing controllers. Note I have my fingers up the WHOLE TIME until I simultanously press them at the end. (In which the right trigger gets stuck, haha):
https://www.youtube.com/watch?v=RRFoQj-bDvo


I'm going to try requesting Meta Support a replacement/modification of my controllers to not have the magnets and see if that improves things.

I'm having the same issue. I'm on my third set of controllers on version v57 and all of them have the same issue.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?