Showing results for 
Search instead for 
Did you mean: 

Quest2 Won't Cast to NVidia Shield

Honored Guest

Quest 2.  All updates are installed.

Oculus Android App.  All updates are installed.

Nvidia Shield TV Pro.  All updates are installed.


All devices are on the same network.


When using the VR headset, I can cast to the app but it won't cast to the NVidia Shield TV Pro.  The Shield has a built-in Chromecast.


I verified the NVidia Shield is working by casting from a different device.  No problems; works perfectly. 


Tried casting directly from the headset (to the Shield device).  It tries for a few seconds and then shows an error.


Tried casting to the app, and then having the app redirect to the Shield.  Again, it tries for a few seconds and then shows an error.


Given that (a) all devices are fully updates, (b) the NVidia Shield definitely works with casting (tested with other devices), (c) all devices are on the same network, and (d) I've tried with the NVidia shield both wired and wireless...  I suspect something is wrong with the Quest 2.


Has anyone else successfully casted from the Quest2 to the NVidia Shield?


I don't have an answer but I do have exactly the same issue, only it's with 2019 Shield TV (non Pro). 


It definitely seems to be an issue with the Quest2. I will try to see if it will cast to Fire tv stick today but I won't be replacing my Shield so still need a fix. 

Ok. Give this a whirl. For "some" reason, I needed to cast any old rubbish from my phone to Shield TV. Then turn it off.

When I now try casting to Shield from either Oculus app or Quest 2 headset it now receives the cast stream. 


It's like it needs something else to wake it up. But it's been perfectly fine since

Not applicable

So shield pro with all the updates and can't get it to go.  Also is the indicator a red x in the vr unit?  So I have had a green one also but nothing on the shield.  Stupid question but we're talking samsung phone correct?

Glad you were able to fix this issue! If you have a moment to drop some more tips about this, I know someone here would love to hear it!

Genesis does what Nintendon't! Send me a DM if you have questions. I'm happy to help!

Hi, The issue here as I see it isn't with your Android phone and it's probably not isolated to any brand. 

While Shield has built in Chromecast, oddly the Quest 2 wasn't able to cast a new stream to it. The error messages all implied cast cannot be started etc .


So instead, open YouTube on your phone and try casting to the shield which should cast fine. Now, close that stream and attempt to stream either from headset to Shield (so from headset menu) or through the Oculus app on your phone. Make sure headset, shield and phone all on same network and hopefully you get some success.

Honored Guest

I'm having the same issues with a brand new Vizio V series tv with chromecast built in. Everything is on same network and they all see each other but all I get is casting error. The whole reason behind buying this tv was because meta said tv must have chromecast. I tried the casting from YouTube, but didn't fix the quest 2 casting error. I was able to cast from my phone using YouTube, but didn't affect the quest 2 at all.

Hey @Curry0981! We know how much fun it is casting your Quest 2 to a TV for friends and family to enjoy, we'd love to get this sorted out for you! We have a couple troubleshooting options on our site, which can be found here. Keep in mind that TVs with built-in Chromecast or other smart functionality may be supported, but compatibility can't be guaranteed with all models. If you continue having issues casting, definitely reach out to our support team! We're always happy to help.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

What would be awesome is if there was a definitive list of supported devices. Not hey go buy yourself a chromecast device and maybe it will work.

We know this kind of situation is never fun, this isn't the experience we aim to provide. If you continue having issues with AirLink after trying out the troubleshooting, definitely reach out to us so we can look into this further! Please click here or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message. We're here to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!