Showing results for 
Search instead for 
Did you mean: 


Honored Guest
Hi, I have a serious problem about SENSOR ERROR on my rift S. Tried ALL THE THINGS THAT SUPPORT ASK TO ME : 


  1. Unplug the Rift's DisplayPort and USB cables from the PC
  2. Remove Facial interface by carefully pulling it straight out (It may help to remove one side a time).
  3. Disconnect the headset cable (connected just above the left lens), it will pull straight out.
  4. Push cable into the socket; the cable only fits in one way, to ensure it it goes in correctly, make sure that the triangle on the cable is facing up.
  5. If needed, re-clip in the cable to the clip on the headband.
  6. Reinsert the Facial interface.
  7. Plug the cable back in, and test.

If the issue remains, please use our log gathering tool to generate some logs for me to review. This will help me determine if there are any conflicts present in the configuration that could be causing the issues you're experiencing. The steps to generate logs are:

  1. Open the Run window (Windows key + R).
  2. Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
    • The above link is the default directory. Bear in mind that if you installed Oculus Home to another drive you will need to update the command with the correct file path.
  3. Select the checkbox next to ‘Full logs’.
  4. Select "1 day" from the "Collect last" drop down list.
  5. Wait for the log collection to finish. This can take some time to complete.
  6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
  7. Attach the newly created zip file to your next support response.

I look forward to your reply.



Thank you for reaching back.

Please try another USB 3.0 port .

Confirm your camera permissions are set correctly:

  1. Open your Windows settings
  2. Click Privacy
  3. Click Camera
  4. Change your "Allow apps to access your camera" setting to "On"

Install the latest Oculus drivers. To do this:

  • Close the Oculus app.
  • Press the Windows key + R on your keyboard to open the Run command.
  • Enter C:\Program Files\Oculus\Support\oculus-drivers.
  • Open oculus-driver.
  • Open the Oculus app and then try to connect your headset again.
  • Restart the Oculus app on your computer.

Let me know what happensHello,

Thank you for the update.

If you are using any adapter or extensions besides the included mini display adapter please remove them for testing.

Please try repairing Oculus Home using the steps 

I also suggest enrolling in our public test channel to try our new beta update. You can see how to enroll .

If the issue continues the next step would be a clean uninstall/reinstall of Oculus Home using the specific steps below:

  1. Backup any necessary content.
    • You can find steps on how to do so by 
  2. Disconnect your computer from the internet.
  3. Reboot into Safe Mode.
  4. Uninstall Oculus Home using the Control Panel.
  5. Delete all Oculus folders from the following folder:
    • C:\Program Files
  6. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  7. Restart your computer in normal mode.
  8. Reconnect your computer to the internet.
  9. Install Oculus Home again using the setup tool from our website 

Please note that you will not be able to submit any automated refund requests for your most recent app purchases after completing the uninstall. You can request them to be manually done if needed at all.

If you end up reaching this last step please gather me some fresh log files and let me know if it worked.




They will exchange it. They need to go through these steps first though to make sure the problem is the headset, even if you've tried another Rift-S.

It's how component manufacturers deal with RMAs'. I had pretty much the same deal with PC components that fail, especially if they're the ones paying for the postage.

Also, Oculus haven't asked you to format your PC (unless there's additional correspondence to the above) so if you're not sure how to do that, just do the things they've asked.

On a side-note, I've just had to RMA'd a washing machine drum that was delivered with a poorly fitted bearing, I had to send them a link to a video on my channel of the drum rotating before they sent the return label... the postage back to Germany isn't cheap I guess.

Intel 13700K, RTX 4070ti, 64GB Corsair Vengeance DDR5, Asus ROG Z790-A, Samsung 2TB 990 Pro M.2 (x2), 4TB 870QVO SSD, Corsair H150i Elite Capellix AIO, Corsair 5000D Airflow, Windows 11 Pro 22H2 (10.0.22621)

Honored Guest
Its ridicolous, they ask to me another test, another useful test that Ive done before . Im not happy about this service, I'm a VR developer and I need to work. They say this to me, tried to do, and nothing else was change. Shame on oculus support, they take time (1 month of message) and no warranty change .

Thanks form contacting Oculus Support.  I'd be glad to assist you regareding your issues with sensors.

Appreciate the logs that you sent.  

Upon checking, your computer is strong enough for your Rift S.  I've also noticed that your GPU was last updated on 15 May 2020, please update it by

I am seeing that you are running Windows 10 Build 18362 (1903~ 2019-05-21) . The most updated Windows 10 Build is 19041 (2004~ 2020-05-27). To get the most updated Windows 10 Build please follow this then reboot your computer.

Please  to join or enable the Public Test Channel program. The program gets pre-release builds of Oculus software that you might be interested in, even fixes before anyone else gets them.

In the case that the above steps do not resolve your issue, please try these further troubleshooting steps:

  1. Open Device Manager

  2. Go to Universal Serial Bus Controllers

  3. Uninstall/remove the Rift S sensor items listed

  4. At the top of the Device Manager window, click Scan for hardware changes and then wait for the items to repopulate back into the list.

Please let me know if this has solved the problem. I look forward to your reply.

The request to enrol in the beta test program was in the first message from yesterday's post and in today's message, did you try that? I assume that they suggested it again because it wasn't showing up in the log file you sent.

To recap, they've asked:

1  Reseat the display port cable at both ends (PC end and headset end).
    If that didn't solve the problem gather and send the log files.

2  Clean re-install Oculus app
3  Enrol in the beta test program
    If those steps didn't solve the problem gather logs again and submit them.

4  Update graphics drivers
5  Enrol in the best test program (again)
6  Re-install the sensor drivers.

Regarding updating Windows, your build isn't old so I think you should discard that point as a few people have reported problems with the latest build.

Did you get the latest message today? your first post was yesterday so I'm just wondering when you say it's been a month has there been any previous correspondence?

When you say you 'tried to do', are you having difficulty doing any of the things they've asked?

Well, all the things they've suggested seem reasonable (except for maybe the Windows update) and they're all pretty quick things to test, so I'd just try them. And if you've done them, then let them know, I doubt there's much more on their list. But if you have a problem doing anything they ask, let us know.

Intel 13700K, RTX 4070ti, 64GB Corsair Vengeance DDR5, Asus ROG Z790-A, Samsung 2TB 990 Pro M.2 (x2), 4TB 870QVO SSD, Corsair H150i Elite Capellix AIO, Corsair 5000D Airflow, Windows 11 Pro 22H2 (10.0.22621)

Honored Guest
Maybe I dont understand very well..the message that I copied in the first post are so many message with me and oculus support,isnt an unique message. I make all the things that they want . now the guy that follow this pratice is changed and they ask again the same things (like beta channel)

For tried I say " I tried " because all of this things are "try" not a " solution " . 
I'm a VR developer and I know how a computer works and how to do
And.. dont forget, I have used another rift s (from my brother) on my pc, and It works. So its simple to know the problem. I replied after this message. I hope tomorrow they change in warranty definitely.

OK I understand what you mean. So your first post includes several messages and suggestions that were being given. That's ok if each suggestion from Oculus isn't being repeated, which it didn't look like it was but not so good if that's all taking a long time.

Hope you get this sorted out without too much more delay, I've had similar delays getting refunds/replacements and it's not always as quick and simple as it should be.

Intel 13700K, RTX 4070ti, 64GB Corsair Vengeance DDR5, Asus ROG Z790-A, Samsung 2TB 990 Pro M.2 (x2), 4TB 870QVO SSD, Corsair H150i Elite Capellix AIO, Corsair 5000D Airflow, Windows 11 Pro 22H2 (10.0.22621)

Honored Guest

i have this error from analys


[Service_2023-05-30_22.42.45.txt] 30/05 22:46:05.224 {!ERROR!} [KMHealth] USB connection failed via pc_hal_sensor_data_read


I had this device working before with a usb 3.0 extesion usb port in pci expres but now i don t know what s wrong...

Hey there, @Christian.badea.31! We hate to see that you are having trouble with your Rift S sensor not being read on your PC. We know how having to deal with this is keeping you from fully enjoying VR, and we would be happy to help you with this issue!


Could you please let us know if you have tried any of these troubleshooting tips to help resolve your issue?


  • Reseat USB cable from the PC.
  • Reseat cable from the headset.
  • Reboot the PC.
  • Check your Windows camera settings.
  • Update all of your drivers for your PC.


Please let us know if you have tried these troubleshooting tips and provide as much information as you can about what you are experiencing. Once we have more details, we will be able to better assist you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @Christian.badea.31! We're just checking in to see if you still need assistance with your Rift S sensor. Please let us know, and we'll be happy to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!