cancel
Showing results for 
Search instead for 
Did you mean: 

Referred App keeps showing Invalid Link

MintyFishy
Explorer
I'm currently having a problem on any app referral links. It keeps showing me an Invalid Link page regardless of who send me a referral link. I've already tried unlinking my Meta account out of my Facebook account and have tried using private/incognito browser to accept the referral link. Unfortunately, they still gives me Invalid Link page. 


247 REPLIES 247

Well that blows my theory on eg if people had potentially bought £400/$500 of games with referral discount in the year......and of course totally disproves the BS excuses that CS keep giving which make zero sense whatsoever, cos they're simply not looking into the issue.  Did you accept any referral for the main headset credit before even buying the headset? Or it wouldn't even allow you to accept that before even buying? How can someone buy a headset, on the basis that they're going to be able to get credit to get them started too because of the referral, but then find "oh this offer you are offering to everyone you've decided not to include me"

I haven't accepted any referral before configuring the headset (thus creating meta account). I was aware that there is 30$ reward, but haven't read the details on how to redeem that until some hours into playing around with headset. I have contacted the support and they actually did add 30$ to my balance 🙂

The app referral thing still doesn't work though. Maybe also should contact support?

6m0n
Honored Guest

when I click on a link such as

https://www.oculus.com/appreferrals/360Pov.org/2448060205267927/?

 utm_source=oculus&utm_location=2&utm_parent=frl&utm_medium=app_referral,

the app opens and nothing happens, I can't take advantage of the discounts?

Greetings @6m0n 

What ever device your on restart that device and turn it back on, wait for 5-10 seconds then turn in your device. With this is still happening, get in contact with Meta to see how to solve this problem.

6m0n
Honored Guest

It doesn't work.

I tried to reinsintall the app .

 

😞

It doesn't work.

 

I tried to reinsintall the app too .

Greetings @6m0n 

Reach out to Meta about this problem.

Same referral link problem when i accept an invite it says Unable to accept the invitation

Before, I tried to contact Meta with the app but i have no response?!

I contacted them I will see if they respond

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?