Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest 3 Elite Strap with Battery only connects for a few seconds

Honored Guest

Is anyone working on the Quest 3 elite battery issue?  It charges but won’t connect to the headset for more than a few seconds, meaning you cannot charge through the back port.

707 REPLIES 707

Maybe they've figured out shipping since then. The email I have has 3 labels attached. One is the shipping label and of the other two; one is an air "cargo only" sticker warning about the battery, and the other is a hazardous material or something one that's also warning about the battery.

So it can def. be shipped back.


I will still push back and say you will send the faulty one back as soon as you receive the new one it’s faulty not like they need it back to check prior to sending a new one out and not like it’s an isolated incident either 

Yeah I tried to push back twice. It just doesn't seem worth my time to talk to support again. I can return it, hopefully get a new one and finally have a working setup.

At this point my attitude towards the quest 3 is that it's a great headset plagued with avoidable issues. I bought the quest 3 and the elite battery strap on release day. The headset had a dead pixel and now the strap is dead. After they replace the strap I will have literally nothing of my original order.

It's just kinda sad ya know.

Honored Guest

I'm having the same problem as many owners of the Elite Strap with Extended battery. AND this is the second headset that is having the problem. I returned my original elite head strap because it had this problem. I received the replacement on Friday, and by noon the next day the extended battery wasn't working and showing the exact same symptoms as my first one.


Solved: [Resolved] - Quest 3 Elite Strap with Battery only... - Meta Community Forums - 1092846 (atm...

Your "Solved" issue only sends you to a support page where the only accessory you can submit an issue with is the charging dock!! 


I can’t seem to find the solution steps on here. Sorry I’m new here

There is still no solution, i have the same problems with elite strap 🤬

@mattwinen wrote:

I can’t seem to find the solution steps on here. Sorry I’m new here

The solution that worked for me was to startup your Q3 with battery strap connected and then press and hold the strap's rear reset button for 12-15 seconds.  This then recognizes it when you hover over the left side of the battery icon in your quick settings menu/panel.  I've only needed to do this a couple of times over the last month I've had it. 

Also, like the Q2 Elite battery strap, after fully powering down and recharging it (green light) if you aren't going to use it the rest of the day you're best to disconnect the elite strap battery cable or the strap battery will discharge 10-15% overnight. 

Otherwise, my Q3 Elite battery strap continues to work very well and I find it makes my Q3 one of the most comfortable headsets I've ever owned.  I've found, because it's so well balanced you don't need to crank the tension all that much and I don't need to even loosen in to take it off, and puti it on like a hat.  My older Q2 battery strap required me to loosen/tighten it taking it on/off.  Anyway, I hope this helps mate and welcome to the Q3 club!

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

Tried doing this, it worked for about 5 seconds then the headset stopped recognizing the battery once again.


my strap stopped working after 2 days, got a replacement, also stopped working after 1 day. rerutned both and waiting on my BOBO VR. META is very annoying for not addressing this. what is going on? And why is it still being sold?

This is very annoying, my replacement also stopped working, idk why they are still selling them. literally all stopped working.