cancel
Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest Link cable connection to PCVR doesn't work after v57 update

Shrapnel5
Explorer

I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

3 ACCEPTED SOLUTIONS

Accepted Solutions

Shrapnel5
Explorer

I can't edit my own post so here's my update:

Turning on developer mode for my headset via the mobile app got me reconnected. I do not have PTR active.  Try this until a real fix gets implemented by the team.

View solution in original post

TheAntiSocializer
Meta Quest Support
Meta Quest Support

Hello everyone! I wanted to check in on this thread, as it's been a couple of weeks since the latest update. With our engineering team confirming the most recent update should have fixed this, If anyone is still facing this problem, please provide the same information as before in this thread: Headset and PC app build versions, troubleshooting steps attempted, and any possible workarounds you may have. We'll make sure we get this information back to the team for review. Additionally, if you'd like, please feel free to also reach out to our support team through a ticket to continue troubleshooting there. We're here to help, and your feedback is truly appreciated. Thank you!

Sometimes it's okay to be a little Bing Chilling

View solution in original post

IIIShadyIII
Honored Guest

I've made a detailed post on Reddit about a potential fix for this problem, hopefully it should work out for most you guys. You can view it here

View solution in original post

430 REPLIES 430

Recently today I was using my oculus link and playing "Vertigo 2" on my Oculus Quest 2. I noticed some jittering and bugs so I decided to restart my computer. Next thing I know for some reason my Oculus desktop app cant seem to detect my Quest 2 but can recognize it in air link? I have nothing wrong with my Quest or pc specs, in fact they're overboard with the requirements. And now every time I boot up the Oculus desktop app, I notice a notification saying "We can't find your headset. Please connect your headset" When I don't have anything connected to my pc or my Quest 2? Can anyone please help with any type of solutions, I've tried every I can and still no hope.

P.S. Every time I restart the Oculus app, for a split second an error pops up and says my quest cannot run on my current hardware. Yet I have a NIVIDIA GeForce 3050 (Not a laptop or a Ti)


Edit here: Apparently the new oculus update has been officially produced, meaning there is no solution as of now for oculus link. Meaning we're FORCED to use Air link, yet from its terrible performance issues. Oculus really needs to step it up!! They've been having issues for updates for years now!

I'm having the same problem, I've straight up reinstalled the Oculus software on my laptop TWICE and restarted my laptop more times than I care to count, I'm fairly certain the last update did this... I think.

Having the same issue - everything worked fine until I took a Oculus Update for my Oculus 2 to v56 and now the device cannot see the host PC and the Oculus PC app says the device is not found. I can see the USB device in Windows USB devices so it is some issue with Oculus.

As the title says, I just updated to the most recent version for oculus on my pc and now it wont recogize my HDMI from the headset anymore... Anyone know what i can do to fix it? 

I tried reinstalling the patch, rebooting the pc and disconecting all the cables etc and reconnecting again...

All help is welcomed, Best regards david. 

Same problem. Air Link works fine, but USB connection fails. I got update today, before them everythink works fine. 

I had the same this morning.

But since I'm playing with a linked Quest,  I don't know if my tip will help you.

I could solve it by enable PTC on Oculus pc app.....it 'will update to v57 and my headset is now detected again.

I was so relieved.

Hope it will work for you too...keep my fingers crossed🤞

I got the update to v56.1 this morning and since then the pc could not detect the Quest 2 anymore.

I'm not sure, if we both have the same problem, but.....I solved it by enabling PTC on Oculus pc app....it updated to v57 and the headset is detected again.

You could give that a try.

I'm pretty happy that it worked 😁

 

Hey there, I can help you with that. You can try these things you can try to fix your Oculus Link issue:

 

Restart your PC and Quest 2. This is often the simplest and most effective way to fix software-related issues. Make sure you are using a USB 3.0 cable. Oculus Link requires a USB 3.0 cable to work properly. If you are using a USB 2.0 cable, it will not work. Try a different USB port on your PC. Some USB ports are not as powerful as others, and may not be able to provide enough power for Oculus Link. Enable USB power management. By default, some PCs will disable USB power when the computer is asleep or in standby mode. This can prevent Oculus Link from working properly. To enable USB power management, open Device Manager, expand the Universal Serial Bus controllers tree, right-click on your USB controller, and select Properties. Click on the Power Management tab, and make sure that the "Allow the computer to turn off this device to save power" checkbox is unchecked. Update your graphics drivers. Outdated graphics drivers can sometimes cause problems with Oculus Link. To update your graphics drivers, go to the website of your graphics card manufacturer and download the latest drivers for your specific card. Factory reset your Quest 2. If you have tried all of the above and you are still having problems, you can try factory resetting your Quest 2. This will erase all of your data, so make sure to back up your files first. To factory reset your Quest 2, go to Settings > General > System > Advanced > Factory Reset. Perform these steps one at a time and check if the issue is resolved after each one. I shared what I got from them. This will help you identify the specific cause of the problem. Hopefully, one of these steps will help you get your Oculus Link working again so you can enjoy your VR experience without any issues.

Thank you for telling me this, I'll try it when I get the time to and if it works i'll update you on it!! 😁

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?