Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

372 REPLIES 372

Thanks for getting back to us so swiftly! As for your cable, when it comes to 3rd party accessories we can't guarantee they will work long term with our software/devices so we would recommend testing out a new cable just in case the issue lies with the cable.

If that doesn't work, however, we'd still be more than happy to help make sure everything is fit to run. To do so, we'll need some sensitive information which is best shared through a private message. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


So i have a quest Pro, which i only use for IL-2 DCS and MSFS2020. Up until yesterday it worked fine. Now it stopped working. Headset powers up, but when you go to de link thingy it keeps searching indefinitly. I have bought the crazy expensive usbc cable when i also bought the headset end of may this year.

Nothing really happened with it that could cause this i think.

Got the headset into factory settings yesterday,  annoying as **bleep** cause i dont have a newer type phone and have to wake up the wife and beg her to reinstall the studid app you only need for setting up the freaking headset.

Worked after that for a couple of hours, tonight i want to experience VR flightsims again, but after 3 hours of trying im giving up.

Have tried reseating all usbc connections, turning them around aswell. repaired the desktop app,didnt help either.

All usb devices al in permanent power on mode in the device manager.

Any clues?


jujst found this nugget of info somewhere around here :

"Yes, the update to v56.1 that causes this.

I had the same problem this morning.

For me the only solution was to enable PTC in oculus pc app.

Its updating to v57 then and the headset is detected again.


Well there's 3 hours of my  life i'm never getting back.. never mind the frustration.

Thank you so much for this! I was having the same issue and thanks to your solution I only lost two hours of my life! 

Exactly the same.  For no reason PC app doesnt see headset anymore even though its connected to PC.  I can only connect quest 2 via air link which I dont want to do. Tried all the META suggestions and nothing works.  God i wish they cared about PCVR as much as they did standalone. 



Dude do this.  It solves the issue.  How these updates are not checked before pushing?!!

"Yes, the update to v56.1 that causes this.

I had the same problem this morning.

For me the only solution was to enable PTC in oculus pc app.

Its updating to v57 then and the headset is detected again.


FYI - Once you activate PTC it takes about 20 seconds before update requests comes up


Thanks that worked after i tried everything else and chewed out everyone in the house for someone messing with my setup. guess i have some apologizing to do now.


Just happened to me right now.. Can't believe oculus has been folding this much in over a week, they really need to get their stuff together!

Meta Quest Support
Meta Quest Support

Hey guys. Something we've seen to help users with their headsets connecting to their PC after it updates is to be sure to update your GPU drivers directly from your GPU website. Once users do that, we've seen them be able to connect their headset to their PC afterwards. This link is for NVIDIA-based GPUs, and this one is for AMD GPUs.

If your drivers are updated and you still can't connect your headset to your PC, I recommend sending a private message to @MetaQuestSupport so our support team can look into this further.

I'll give an @ to the support team but I'm already on the latest drivers for nvidia (8.22), on a 4090 PC.