Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

375 REPLIES 375

The last three weeks have shown me I need to invest in a HP Reverb G2 and leave Meta behind. Meta is only interested in Wireless headset gaming and don't care to support PCVR, Its painfully Obvious now. The only thing they're lacking is an Official Statement stating their stance on PCVR support. I knew a day would come when Meta buying out Oculus was a bad thing. I think that day has come. 

Hey there, @Rdrockt! We were just checking in with you to see if you were still needing assistance. We look forward to hearing from you, and want to ensure you're well taken care of. We hope you have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


You have to be kidding me. Link Cable PCVR connection broken with the update a few days ago. Fixed with the hack/workaround of opting in to the PTC. Broken again today. I'm thoroughly fed up with this. Air Link isn't an option. 

Here's my version info if it remotely helps anyone who actually might be QA'ing this awful software: 

Oculus App Version (

This needs to be fixed sooner than ASAP. This is just ridiculous. 

I've done all of this.   There was an answer that involved allowing a Beta version of the Oculus driver to load.  That worked until the app pushed a new update.  I am now having the issue again.

This issue has returned the very next day. I've tried v57 and v56.1 and the Oculus app again says my headset is not detected... 

Meta Quest Support
Meta Quest Support

I'm marking this comment as the solution so that people can know this issue is currently being looked into. 

Hey everyone! I just want to say thank you for the information and everything provided. Our engineers have let me know that they are now currently working on getting this resolved.

I'll be checking in consistently and editing this comment to let you guys know the latest news.

Again, thank you and I apologize for misleading you with the solution. It's necessary for everyone to be able to see my comment.

[Edit 9/13] - This developer setup video is not an official Meta video, but someone has provided it within the thread for the meantime as a possible workaround. Along with that, the following has also been suggested:

Put on Quest headset > Go to Settings > Click Developer > Turn on "USB Connection Dialog" > Unplug and replug headset into the PC > Press "Allow" when asked to allow access to files. Let me know if this helps or not and I'll pass it to our team. 
[Edit 9/14] - In the meantime, can everyone running into this issue please submit a bug report stating "USB Link is not detected". This way the team can really see how many people are having the issue. Thanks!
[Edit 9/27] - Users reported updating to to get Link working again. Please be sure you're running this version as it should be good to go now!
Sometimes it's okay to be a little Bing Chilling

Honored Guest

same issue. Ptc fixed it yesterday - broke again today

same problem with my quest 1 

Same. It’s really really frustrating. 

A few days ago, I got the 56.1 and my PC couldn't find the headset after it installed. Followed the recommendation of going to the beta channel and it worked, until now... I got a notification about an update and new drivers, not neither the regular or the beta channel works.  As an IT professional, I know that sometimes bugs get through testing but this is beyond ridiculous. This is like the 3 or 4 time you guys break PC VR. I was waiting for the Quest 3 to drop to upgrade but I think I will explore other options unless you include an opt-out of the automatic updates.