Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

372 REPLIES 372

This shouldn't had happened in any case.


No hotfix or update in the last few hours. Looks like tonight's VR livestreaming is going to be put on hold until they can get their act together over there. 

And here I was contemplating getting  a Quest 3 for VR streaming...  Looks like a G2 is going to be on order soon.

Honored Guest
Since the last Oculus app update, the connection between my Meta Quest 2 and the PC via link cable no longer works. The link cable is not from Meta... but it has always worked very well so far. I would like to downgrade to the latest Oculus app version... but I don't know how to do that. I don't think Meta is that great!


I can't edit my own post so here's my update:

Turning on developer mode for my headset via the mobile app got me reconnected. I do not have PTR active.  Try this until a real fix gets implemented by the team.

Nice!!! That worked for me too.  A few hoops to jump through but I had this going less than a few minutes.

it's good to at least know it's being looked into! especially seeing as this issue is something that I've been loosing my marbles over

Thanks for getting back to us @negativghostrdr! We appreciate you trying all of our troubleshooting, as well as your own. Let's try one more possible solution that has helped others in the past: 

  1. Disconnect the Rift/Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content. You can find steps on how to do so by clicking here.
  4. Reboot into Safe Mode. You can find steps on how to do so by clicking here.
  5. Uninstall the Oculus PC app using the Control Panel. You can find steps on how to do so by clicking here.
  6. Delete all Oculus folders from the following folder:C:\Program Files
  7. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Rift/Link cable and re-test the headset

If the issue continues after trying this, please send us a PM, so we can take a further look into this. To send us a private message please click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

@ep_sode  So nice of you to join this forum 3hrs ago to let us know what you think and generously share all the details related to your issues.  I can certainly see why you’d like to buy something different.  Please don’t let me stop you, lol!

Same applies to your kudos friend @thevibinfrog , lol!

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro

belittling me over my join date to a backwash VR forum is crazy. my input is valid and speaks for many

Yep, I'm done with Meta/Oculus. They don't care about this product for PC users.