Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

375 REPLIES 375

How do you roll back an update?


OMG yes.. thank you so much for this. I thought I was toast. Glad we have such a resource of intelligence in this forum. 

Did you get an update of pc app to v56.1?

If so, that could be the problem.

@Macproracerprovided you some links where I posted what fixed it.

Enable PTC in Oculus pc app, that will update you to v57 and your headset will be detected again.

Wish you luck with that.🤞



I have verified that the cable I am using is good by connecting a Quest unit that I have.  Quest link works fine in that unit.  I have uninstalled and re-installed all Quest drivers on PC.


I had my oculus quest 1 connected to my pc for a long time, I ended up not using it for one year though for reasons, and recently I want to go back to using it. Unfortunately, the device has been disconnected through time and I'm having trouble reconnoitering it.

Right now I'm using the official cable, connected to my mobo through a USB 3.1 Gen2 Type A+C port. The device is powered by the cable but isn't being recognized by the oculus app.

I've tried restarting my pc. Restarting the quest. Enabling, disabling Quest link in the vr menu, forcing updates, disconnecting and reconnecting the cable, but I can't seem to be able to connect the quest to my pc.

What am I missing?

It's not your fault don't do anything wrong.🙂

There are many people having problems since update of pc app to v56.1

Try that here 


hey thank you for your input. Unfortunately, it doesn't seem to be resolving the issue.

Maybe my computer as a whole isn't recognizing the device...? I'm not sure if the device is supposed to show or not on device manager before it's paired with oculus link.

I'm not said you haven't used in a year....maybe the device has to be updated??

Unfortunately, i have only my solution🙁

......If no other user can help, you should contact @MetaQuestSupport 

I know, I know.

I've updated my device, I've updated my app, I've reinstalled my app, I've repaired it, I've uninstalled, deleted the files in the appData, reinstalled, I've installed the adb drivers. Nothing.

I went further. I looked up my motherboard and updated everything. Still nothing, had to go further. I've updated the BIOS. Nothing still, but it's still updating outside of the bios so maybe... possibly... hopefully... it will be detected...

Irony is, I've connected it to my less powerful laptop and my laptop is able to recognize the quest as an actual device connected to it. My current pc.. can't.