Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

375 REPLIES 375

Honored Guest

I worked for the past 24 hours trying to get my VR to connect to my PC. I could hear the sound that it was connected and it showed in my devices, but when I opened the Oculus app it would not connect with the cable. First, I recommend a new cable, if you have had the same one for a few years. My PC read  "faster with 3.0" despite using the same cable and the same USB 3.0 port.  Once I got the new Anker  USB cable my PC read "connected to 3.0". 

Next, here is what I think the problem is....THE PERMISSIONS!!! After a recent update or maybe someone in my house denied permission to use files (this pops up on the VR headset, not my PC).  To get this pop-up option back I had to erase the VR, not reboot. but return to factory default (press and hold the volume down button and the power button until a menu comes up, choose return to factory default). This will erase the entire VR. When it comes back up you will have to download the Meta app on a phone or iPad to complete the setup.  ONCE YOU ERASE THE VR YOU MUST HAVE A DEVICE THAT CAN ACCESS THE GOOGLE PLAY STORE OR THE APPLE APP STORE, DO NOT ERASE THE VR IF YOU DON'T HAVE A DEVICE THAT CAN ACCESS THE META APP.

After going through the meta app setup on my iPhone I plugged the VR into my PC (I already had the oculus app on my PC.) On the VR a box popped "allow device to connect to files" Choose "allow". Immediately another box pops up that says "Enable Quest Link", choose Enable. Finally, I was connected to my PC through my cable. 

I could not find a way to enable or give this permission without erasing the VR. I think on some other VRs or older VR models you could navigate to a screen that would let "allow" if you had denied access previously, but I could not find that on my Quest2. So if anyone has a way to access those options you might not need to erase the VR. I do think it will be important to disconnect my VR from my PC when I finish because these permissions need to be enabled every time and if I ignore giving permission the default might be "deny" since there isn't a way to access these options once "denied" I don't want to take a chance. 

The new cord I purchased was Anker USB-C to USB3.0 (10ft), I believe the link is on the Meta site.  I sure hope this helps.


We all have working cables, there's no need to make this more of a project for users than it is. Thank you for your testing and reporting of this information. It is, however, unreasonable for users to have to do all this to make Link work again. The information you posted is great info for the meta developers, and shouldn't have to be done by users.



Intel i7-7700K, 32GB RAM - nVidia GTX 1070 Amp Edition 8GB GDDR5. Link Cable.



I feel your pain.  I resisted Factory Reset.  Turning on DEV mode got me most of the way back (re-establishing Cable connectivity).  Some time ago I screwed up that DO YOU WANT TO ALLOW CONNECTIONS dialog and it never came up again, but everything worked. Then it broke,  and DEV MODE USB options restored it along with the PC VR LINK.  Then I had to struggle to get my AIRLINK back....

Nice for you that you get it work again.

But it can't be that I have to do a factory reset of the Quest because I got an update of the oculus pc app.

I expect a solution by Meta .....and will be really diapointet if not


So it seems indeed that allowing file access is the way to get Link working...
In prior versions of the software it was not needed, but seems the headset is not discovered if you don't allow it.   So if you have pressed "Deny and don't ask again", that popup isn't comming anymore.  

Some got it resolved by doing a complete factory reset, but I think that is overkill and not needed.
You do NOT need to do a factory reset in order to get that prompt back!

There is a checkbox for that in the settings (System - Developer - USB Connection dialog ).
Turn this on, and when you plugin your usb cable you should get the prompt again.

Now choose Allow (you will need to do this everytime as there is no option "Allow and don't ask again").


Cheers! (hope someone from Meta reads these posts and they fix it so we can connect again with Deny file access)

TRUE! But that check box isn't there without you first going through the motions to set yourself up as a "Developer" I resisted doing that for the longest time, but it wasn't really that bad.  I got the menu on my PC client, but I had to use the Oculus app on my phone to enable it on the headset, which was needed to get the Developer menu with the USB Connection dialog to come up.


Same issue, none of the proposed fixes work. Meta needs to fix it with an update, not us!

Some people want their VR working now, myself included. It doesn't have to be a project for you, put your VR out on trash day (lol).


For anyone watching this space, I just got an update on the PTC ( that has fixed the issue for me.

Rising Star


Got it too.... the headset is detected again with that version.

I'm glad that I waited and did not try the dev mode workaround or even factory resetted the Quest.