Showing results for 
Search instead for 
Did you mean: 

Rift S Crashing and I've Tried Everything


PC Parts Below and Methods I Tried

I've had my Rift S ever since it first came out and so I preordered it off of Amazon. Once when I got it I had so many issues with the software where it just crashed every single time I opened it and I was so close to returning in the headset. Until one day I was able to fix it. After that, the headset was just working perfectly fine for about over 5 months or so... Until my headset started to flicker black every single time I moved my head. I dealt with it for like 2 weeks till I figured out it was my cable, so I bought a brand new replacement cable off of Oculus and it seemed like the cable was much thinner than the one that you get with the Rift S. But it was working completely fine. I also had an issue where if my controllers vibrate they would lose tracking like crazy. So I had to buy brand new ones and it started working perfectly fine by then. 8 months later, my headset started to crash like every 10 - 15 minutes. But as time went on it kept getting worse, like on some game it seemed it allowed me to play a little bit more on less demanding games. So I tried looking for fixes and to see if other people were able to solve this problem. After days of researching and troubleshooting. None of the fixes would work, until one day people I read a forum post saying that people were able to fix the problem by getting a powered USB hub. Then so I did and it worked I was so happy until a month later it started to occur again. So I bought another powered USB hub that cost like $30 and it still didn't fix the problem. Then I bought an Inateck PCI-E to USB 3.0 Express Card, when I went to try it, it just crashed straight away and it was legit worse than using the powered USB hub. Later on, with the issue, I was working on buying a new PC and just transferring the graphics card, 16 gigs of ram, and the same hard drives to the new PC. Once I got the pc all powered up and ready to go I went straight to playing on the Rift S and it still crashed no matter what I did including reusing the PCI Express card and the powered USB hub. Except I was able to get a little more time until it crashed. But at that point, I just gave up and I don't know what else to do. If I need to provide any more information just tell me because I really want this problem resolved.


Methods I've tried:

  • Repairing/Reinstalling the Oculus software
  • Reinstalling SteamVR + my games
  • Checking if everything is up to date (GPU Drivers, Oculus software, SteamVR, Windows 10)
  • Going on the Oculus settings and enabling Public Test Channel
  • Tried every other USB 3.0 port on both PC's
  • Disabled USB selective suspend setting in the Windows Power Options
  • Unplugging all of my other USB devices
  • Checked that the DisplayPort wire connection in the headset is connected properly
  • Ran the Oculus software in Administrator
  • Ending OculusDash.exe and OVRServer_x64.exe in task manager
  • Turned off Power Saving mode in Device Manager for all of my USB ports


Old PC: HP Pavilion 690-0024 Prebuilt

RX 580 GPU

AMD Ryzen 5-2400G CPU

16 Gigs of DDR4 Ram

1 TB Hard Drive

2 TB Hard Drive

400 W PSU

For More Information About The PC: 


New PC:

MSI MPG Z390 Gaming Edge AC LGA1151 Motherboard

RX 580 GPU

Intel Core i7-9700K CPU

16 Gigs of DDR4 Ram

1 TB Hard Drive

2 TB Hard Drive

850 W 80+ Gold PSU


Motherboard Link:


Can't find the 850W CPU but here's the 750W version link:


Inateck PCI-E to USB 3.0 PCI Express Card Link: 


Can't find the first Powered USB Hub that I used but here's the second one:



Accepted Solutions

Hello, thanks for contacting us. We noticed that you're experiencing crashing with your Rift S. A crashing device can really interfere with a smooth gaming experience. Nevertheless, we're here to help! First, let's consider rebooting your Rift S if you haven't done so already. 

To reboot your device, please following the steps below:

  1. Log out of the Oculus Companion App
  2. Log back in

If you need more assistance, please gather logs according to THESE instructions and send then in a support ticket HERE. We'll be happy to get you back into gaming!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

View solution in original post



This sounds like what I've been going through with my Rift S. Started about a year and a half ago. I have tried many of the same steps and I still get crashes. No BSOD, just a black screen, static noise, and the sound of my system rebooting. I haven't replaced any of the hardware but I did get a USB hub which seemed to fix it for a bit but the problem returned. I have a Ryzen 7 and an RX 580 on an ASRock B450 Pro4. For some reason the crashes only happen with Steam games. Titles from the Oculus store have never crashed my system.

Expert Protege

In our post you don't mention what oculus version are you using. From v26 there are many user get crazy for oculus update,because have many device stop working.

i suggest to try downgrade your oculus, find how do thath in this topic:


is longer topic,but i suggest to read all of it.


I bought my Rift S about 3 weeks after the model was released. The problem started a year-and-a-half ago, so I have been experiencing it through a series of updates with versions from the first six months of the Rift S release. Quite a few versions. I am on the beta public test channel, though I'm not sure if that had anything to do with my issue or not. It *seems* be related to the Radeon software. I will take a look at the link and see if that helps, thank you.


For the past week or so I bought a new cable and it's been working completely fine ever since. I have no idea why the problem was coming from the cable since it had no bends or anything and it looked completely fine to me. Right now I do have a small issue with the new cable though. Whenever I plug in the headset, most of the time it just doesn't detect that I have the USB plugged in. So I have to keep unplugging the USB and plugging it back in until it finally detects it. To be honest, it's not that big of a deal, I'm just happy that it works. I'll try to keep you guys up-to-date with anything that happens or any issues that appear.

where did you buy the new chord? was it oem? did you just buy it on amazon? im in your same funk man idk what to do...i packed it away with the intention of never using it again and buying the hp reverb instead but i broke down and im now trying to get this thing running again. 

Yeah, that's been happening to me, except its been happening on all platforms. I've tried to do the same steps everyone says to do, yet nothing happened.

Honored Guest

I was told i need to downgrade my CPU after i got a problem with my headset causing my pc to crash every time it is plugged in. I dont know what to do to fix it. The rift s worked fine one day the next day I got these issues out of no where


2021-12-17 (2).png



we need to sue this company for breech of consumer contract. Discontinuing a hardware that supports the software we invested in... if you had a rift S you CANNOT USE A QUEST OR QUEST 2 TO PLAY YOUR TITLES. SO WHEN YOUR CABLE DIES LIKE MINE DID YOU WON'T BE ABLE TO GET ANYTHING OUT OF YOUR OCULUS ACCOUNTS.



we need to sue this company for breech of consumer contract. Discontinuing a hardware that supports the software we invested in... if you had a rift S you CANNOT USE A QUEST OR QUEST 2 TO PLAY YOUR TITLES. SO WHEN YOUR CABLE DIES LIKE MINE DID YOU WON'T BE ABLE TO GET ANYTHING OUT OF YOUR OCULUS ACCOUNTS.