cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S DisplayPort keeps disconnecting

deadshot0130
Explorer

My Rift S recently just stop working because of this well-known DisplayPort issue. The issue I'm talking about is where after connecting the Rift S, both connections will seem OK for a few seconds, but then the DisplayPort disconnects and you're left with one of these status screens in the Oculus app

Here's everything I've tried so far, collected from forums and other sources:

  • Rebooting

  • Uninstalling and Reinstalling Oculus app (I even went into AppData to make sure there was no trace when uninstalling)

  • Disabling power-management USB suspend options

  • Disabling USB suspend on USB devices through Device Manager

  • Updating video drivers

  • Reinstalling video drivers

  • Connecting the headset through every available USB 3.0 and USB 3.1 port on my computer.

  • Connecting a single monitor through HDMI rather than DisplayPort

  • Disconnecting all other non-essential USB devices

  • Checking the seating of the connectors on both the computer side and headset side

  • Checking the integrity of the cable, connectors, and headset, for kinks/frays/etc.

  • Unplugging audio devices from the headset

If you know a fix please share.

I followed this list from this forum if you are curious: https://communityforums.atmeta.com/t5/Get-Help/Rift-S-owners-who-had-the-Displayport-issue-and-FIXED...

hrwcjnbek1g2.png

y07o9desfx64.png

20 REPLIES 20

MetaQuestSupport
Community Manager
Community Manager

Hello, @deadshot0130.

PC VR is truly a great gaming experience, and is arguably the best way to play VR, as you can take advantage of the power of a tower! While Rift S is quite old, we would love to see if we can get you going again as they should still work at this time.

First, we want to ensure we know your exact issues, and would love to collect some further information:

  • Be sure your headset is not plugged in when updating, installing, or making any changes, this can cause problems.
  • When did these issues start? Did your headset work fine in the past?
    • Did it work one day, and break the next, or have you not used it for a while and tried using it again recently?
  • If it previously worked, have any hardware parts been swapped out since it last worked?
  • Otherwise, What GPU do you have? Model and driver version would be helpful!
    • We always recommend updating the drivers to the latest version as well.
  • Does the headset work at all for those couple seconds? Or does it act like nothing is happening at all in the headset?
  • Have you tried another device in the same display port, just to be extra sure it is not the port?
  • Do you have multiple monitors?
  • Are you using a Laptop, or a Desktop?

Next, we really appreciate the steps you have taken, and we would love to provide some further steps to try:

  1. Launch the app installer again, as the program is already installed, it should offer the option to "repair" the app.
  2. Double check your GPU drivers are updated to the latest versions, and restart your PC if updates are done.
    • You did mention updating your Video drivers, but just be extra sure!
  3. Re-seat the cable from the headset, remove the facial interface, and then remove the cables from the headset, make sure they are clean (Canned air is best) and then firmly push them back into place.
  4. Try another PC if possible, this can really help clarify if there is some weird interaction going on causing problems.
  5. If you have a CrossFire or an SLI configuration, please remove one of the graphics cards as Rift S does not support the use of multiple dedicated graphics cards.

Please review the above information, and let us know if anything changes! We would love to review further to see what else can be done to get you up and running in VR again.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hey again, @deadshot0130. Feel free to reach out any time if you need further assistance. We would love to review further anything we can, just let us know!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

YungCinnamon
Honored Guest

Hi, I'm having the same issue. I haven't used my headset in a few months, and no matter what I do, it just tells me that my displayport is not connecting. Did you find a solution?

Hello, To answer the questions above
. The headset has not been plugged in when up updating, installing, or making any changes.

. Yes, my headset worked in the past. I hadn't used my headset for a few months before the problem happened.

. Yes, I got a brand-new computer with brand-new everything. I did suspect that It could be me switching from an NVIDIA card to an AMD card, but I tried to plug it into my old computer and the same problem was occurring there as well. I have an AMD Radeon RX 7900 XTX, and the current driver version I am on is 24.5.1.

. Kind of, The headset will read that both connections are fine for a few seconds, but then the DisplayPort disconnects, as for inside the headset it's just black.

. Yes, I have tried to plug it into my old computer that It did work on in the past, however the same problem was happening there too.

. I do have multiple monitors, two of them. I have tried to unplug one of them and still nothing.

.I have tested the DisplayPort with different devices and have confirmed that the port works

. I am using a desktop.

I have tried all the other solutions that were recommended and still nothing.

Unfortunately no the problem is still happening, may I ask what GPU you have?

Hey @YungCinnamon! Thank you for taking the time to share your recent experience with the Rift S device. We also like to thank @deadshot0130, for providing some insight on the best way to get this matter resolved for you. If you haven't already, we advise you attempt the providing troubleshooting steps from our fellow community user. Please do not hesitate to reach back out to us if you have further questions or concerns. Have a legendary rest of your day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey again @YungCinnamon! We just wanted to follow up with you on the issues you were having concerning the Display Port on the Rift S device. Did you still need assistance with this matter? Talk to you soon! Have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

antobianco
Honored Guest

Hi, I also encountered the same problem these days just while I was using my oculus rift. My pc is updated with all the latest drivers and my visor worked fine until yesterday.

Anton

Hello there, @antobianco! We understand you were also encountering this with the Oculus Rift, and we can look into this together. If you could provide some more information on what is encountered when connecting the headset, along with any troubleshooting steps that have been attempted already, this can help narrow down the possible cause to help in our investigation. We look forward to hearing back, and have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?