Showing results for 
Search instead for 
Did you mean: 

Rift S flashing red and firmware update loop

Honored Guest

Hi, I have been stuck for 2 weeks now trying to fix my oculus rift S which works on my old pc. I have recently just gotten a new computer that I built myself, and everything works except VR. My motherboard has a VR ready USB port and yesterday I even spent another £100 on a new motherboard as someone suggested it may be an issue with the motherboard. I have tried so much with oculus support but nothing seems to be helping. 

Pc specs: Ryzen 5 3600, 2060 6GB, 16GB of ram, i have tried on a B550M DS3H mobo and a B450 Gaming pro carbon max wifi mobo. I brought my 2060 from my old pc so it is not a display port issue, I have switched mobo and doesn't seem to be the issue, I have tried a different user on this device with admin perms, I have factory reset my pc, I have all drivers up to date (which i know of). This troubleshooting has me really down lately because I have went from using my vr every day to not using it at all for 2 weeks straight. If anyone has any help at all, please let me know.