Showing results for 
Search instead for 
Did you mean: 

Rift-S framedrops/stutter/micro-stutter in all UE4 content

Level 4

Hi, I've been through Oculus Support with this and they replaced the HMD.  However, the problem exists on the replacement, so I guess the one I sent back was in a working state. 


In every Unreal Engine 4 game or content I am having very poor performance that shouldn't happen on my hardware.  I have tried other PCs and the problem exists on those, too.  Today I cleaned my main nvme drive and installed Windows 10 Pro from fresh.  No other drives are currently connected. 


I recorded some gameplay from the popular UE4 Aircar demo that is found on Oculus store, but I can assure you that it behaves the same (with minor variation, some even worse) in all UE4 content (many games).




At first I am in the Aircar menu scene, and here the performance seem mostly OK, but as soon as I am in the Aircar things go a bit crazy.  I suspect there's something more going on than a rendering problem.



Ryzen 7 3700x

32GB 3600mhz RAM

Gigabyte Aorus x570 Elite - F35 (tried newer and old bios', none address the issue)

Asus TUF OC 3080 12GB (happened on a 3080ti, too)


Windows 10 Pro 21H2 fully up to date

Nvidia 512.77 drivers (tried them all)

AMD Chipset drivers

Oculus software upto date


The problem also exists on an old i7 PC with a GTX 1080 (same OS version).  It seems like I have ruled everything out other than the Oculus Software.


I also tried it with an Xbox controller (Aircar supports it) and took the batteries out of the Oculus motion controllers to turn them off.  The problem was still there.


Level 5

Hi mate, I've also been troubleshooting the drops with v39 and v40ptc 

For me, it's whenever the controllers and being used with my cv1, I don't seem to get issues with link on quest 2.


My fix below that could possible help you, I don't have rift s to test.


Anyone that's also having frame drop issues with v39 and v40ptc on the Rift CV1 the cause is controller tracking, after 3 painful days of troubleshooting the fix is simple 


Set OVRServer_x64.exe priority to HIGH and also the game you are playing to HIGH.


Doing one alone does not work it has to be both.


Why this is only an issue on cv1 and not quest 2 with link I really don't know.

Level 5

Please let me know if this fixed for you, I'll be making a video to chuck up as not many people end up here.


I'm interested to know if it's the same cause for rift s, if this fixed for you, would you mind if I link to your recording in the video?


The dips you have to 77.5 seem exactly the same situation as my cv1 dropping to 87.2 

If you were to use the lost frame capture in debug tools I'd hazard a guess that the drops to 77.5 are 2 frames and the bigger drops a bunch of 4-5  

Level 4

Priorities, affinities and every concievable attempt to fix it never worked and it has been this way for months now. Game + Server at high makes no difference for me.  Everything UE4 VR is like this, even a basic UE4 VR Template project in Unreal Engine 4.  I can run a Unity game, Source 2 game (Alyx), CPU demanding race sims like AC and Automobilista 2, Elite Dangerous Horizons, Lone Echo (a few drops near asteroid bases, but I was maxing everything out), Fallout4 VR, Borderlands 2 VR (UE3), Doom VFR, Doom 3 BFG VR Mod (newer build from 2021), The Serious Sam VR ports and more very well, as expected from my hardware.


All my UE4 VR games run terrible and stutter, even from head movement.  As you can see from the video it looks like a synchronisation issue, but nobody will tell me what is going on.


Even if I could confirm it is the Rift S software and that there will never be a fix for it, then at least I would know. 


BTW, the similarity between the problems we were having (the 87.5 and 77.5 drops) was why I mentioned it on your thread.  I certainly do not rule out this relation, but if it is the same underlying issue then it's affecting the CV1 and Rift S differently. 

That's a shame, I'll cover all troubleshooting done in my video anyway as a later part but no doubt you've chased your tail and done it all like me, never know maybe there might be something I've done that's gone a bit deeper, but main thing to rule out oculus especially with recent update and having both server and game.exe set to high, is checking you have openXR runtime in the beta tab in oculus software set to oculus, this sometimes gets changed, even still, see if changing it helps, also checking headset in USBTREE that the rift is showing connected as superspeed, depending on how rift s displays the hub it may say superspeed device working at high speed and report the headset as a usb 2.0 hub if it is like my CV1 but so long as the device is detected as a superspeed device it's seeing the headset correctly, that would also be correct, I always have performance issues when the sensors themselves aren't working at superspeed and that's usually if windows has updated my PCI card drivers over the manufacture supplied, clearing and redoing guardian is another basic thing that can cause issues.


Also if you are supersampling in debug tools or in game make sure that adapter GPU performance scale is set to off and any RGB at all on pc is completely off, not just software, same for uninstalling any hardware info or monitoring or overclocking tools that may have been installed, even if they aren't running.


Also if it's specifically unreal I would hazard a guess at a bad registry file, does this persist with a fresh windows 10 install with just oculus and steam vr games installed and have you reinstalled games you are having issues with to a different drive?


I've never had a specific engine problem so I do feel your pain, the drops I have now are caused by the new rift update (maybe even 3 updates ago I haven't been on it in a while) but it's universally dropping only the apprender, the compisitor frames seem fine, if you are dropping compositor then it's something real funky going on, i swear by using the frame drop capture tool in debug tools as it'll show how many and when it's happening, if it's a patter of a 5 seconds (count frames at 80 per second) then it's absolutely the oculus software, I would be able to put anyone else on my system and they would likely not notice without hud overlay up, it's only because I'm super sensitive to it and noticed that odd miss in beatsaber I checked the capture logs.

The performance profiler in debug tools is also handy to see if it's CPU or GPU lead, CPU itself is harder to pin point as it could be either process put onto wrong cores, not rendering fast enough, usb power states or even the software not polling data fast enough which I guess is my problem I have.


Appreciate you've probably done all of this, if I could replicate the unreal engine issue I'd have better understanding where to start looking as I've done everything else I can think of to fix this priority issue.

Level 4

I've checked all USB, OpenXR is all Oculus, nothing RGB running and it does it on a fresh install of the OS.  The tell tale sign is that it does it on two PCs that are both capable of running the HMD, and there's nothing wrong with the other PC either.   I can only blame the Oculus software, Windows 21H2 or every Nvidia driver.  The most likely is Oculus software.  I am currently running on a single NVME drive with a fresh install of the OS.  There's nothing else I can do other than buy another VR kit that is not Oculus or count my losses and walk away from the tech entirely.  Sadly, I can't refund or transfer all the games and content.

Level 5

Hi mate, I've been tinkering with underclock using msi afterburner, no rivatuner installed, thought I'd try aircar for you.

just firing up, unplayable much like your vid, doing my trick with the ovrserver, the aircar shipping.exe and the aircar.exe to high priority (sort by name to stop them jumping around) it made things so much better, but if msi is open at all it is still terrible even with priority changes, but that's a known 30 series card issue using VR with afterburner, without after burner open, its only very occasional frame drops not a pattern like I was seeing on beat saber.

if you didn't do both the games executables and server, give it a try, its certainly not perfect but its not attacking you with drops like before,.

the performance profiler in debug shows its also the app que ahead causing the drops and nothing to do with compositor again, beat saber only has the one process and making the server same as that exe fixed it entirely, doing both the 2 aircars exes are required for any improvement.

That said, I wonder if you could try it, if it improves but still has those odd drops like i'm getting, how does it fare with xbox controller alone after that?

Level 4

It's exactly the same.  I don't believe it's a 3000 issue.  It's the same on a GTX 1080 on an Intel platform.  It's also the same if I put the 1080 in this PC.  It could be Nvidia drivers, but I've tried so many with no improvement or degradation with this issue either way.   When I made that video I had nothing installed other than Oculus and Aircar.  I even did a before and after test before installing drivers. I left it at MS defaults at first, and it installed the 511.** drivers (my current card only has driver support from January 2022).


It's an odd one that's for sure, but how I set the processes doesn't change the problem.  Aircar was also causing a lot of bouncing in the graph and it seemed random (rapid headroom bounces).  It's the same thing with all UE4 VR games.  They're all erratic, like there's something interferring but nothing is showing up as a problem (I had/have nothing third party installed).


It's UE4 specific and that makes it near impossible to fix without understanding what that engine is doing that all the others I have tried isn't.  Epic Games won't help, because they only care about development on the engine and not how games perform post-release.


If you're also experiencing issues with Aircar, but can work around it to some extent, then we must be experiencing the same or similar problem only on different Oculus HMD types.


Oculus engineers must have some idea.

Level 4

I just did some more testing on the i7 + gtx 1080 system.  I DDU'd Nvidia drivers and installed the 442.59 (March 2020) drivers that predate the 3000s.  The problem is identical.


I was using the Rift S when these drivers were out, so the problem must be Oculus software.  I don't know what version introduced this issue.  I tend to take breaks, sometimes for a few months.

Considering I also never had issues before with aircar I'm also going the way of blaming oculus software now, it's still apprender queue misses, something somewhere in these broken updates is not feeding the applications the right info or at the speed it needs to.


I do not have any stuttering outside of VR, but it does seem some people have unreal engine issues and there is a fix of sorts that I haven't tried yet, note, personally I wouldn't leave this option disabled for normal computer use even if it does fix the issue, my windows 10 install is purely for VR and no web browsing so I will be trying this later tonight in combination with the priority changes, but thats only to rule out windows itself as a culprit, I'll fire aircar up on my oculus quest and see if I still have issues there and report back tonight.

Have you heard or tried this 'fix' before?