Showing results for 
Search instead for 
Did you mean: 

Software bug? Rift s controller thumbsticks randomly get stuck in one direction, triggers don't work

Not applicable
I hadn't payed my rift s in a while and when I came back to it the controllers are acting up intermittently. The controller hardware is fine and nothing is broken. I tried playing defector and the left thumbstick acts as though it is stuck walking to the right. Pushing the thumbstick in other directions doesn't do anything. I tried restarting the game a couple times and it continued to not work right. I restarted my computer and tried playing Minecraft for a couple minutes and everything worked fine again. I then put on No Mans Sky and played it for about 20 minutes with everything working perfectly and then the left thumbstick stopped responding and it was walking to the right by itself again... 

At this point I noticed that when this happens it's not only the thumbstick, but also the grip button and trigger buttons don't respond either. I restarted the game and it worked fine again.... UNTIL after about an hour then THE RIGHT CONTROLLER did the exact same thing, only this time instead of it walking in one direction instead it spins around in one direction (vomit inducing). Again the grip and trigger buttons on the right controller don't respond at all when this happens. After this I tried it again and after a while it did the same thing but with the right controller again. 

I know that it isn't an issue with the recent update to Steam VR because it does it with the Oculus games purchased from the Oculus store (Defector) when Steam VR isn't even running. I have the whole next week off from work and planned on getting a bunch of time in with NMS but I'm finding it difficult to reach new SAVE POINTS when the controllers keep bugging out every half hour... (The loading screen on NMS seems even longer when you have to keep restarting the game over and over).

Anyone else had similar issues to this or know of any way that I could maybe revert to an earlier version of the Rift software or something? Any ideas would be greatly appreciated. Thanks.

Level 2
I have the same problem, and i dont know why, need help