Showing results for 
Search instead for 
Did you mean: 

Solved - Quest 2 First time setup Stuck at 0% update


Just got a new quest 2, started setup, paired, got a new update. But its not at all updating.. Its been 4 hours.. Still at 0% 👌😒.



Accepted Solutions

Retired Support

Hey everyone! Engineering is aware of this issue, and is currently working on a fix. We don't have a specific timeline on when the fix will roll out, but we appreciate your patience as the team works on it!

UPDATE: The fix is currently being pushed out. Please complete a power cycle and make sure the headset is charged before attempting to update to complete set-up.

Have you tried turning it off and on again?

View solution in original post


Honored Guest

my quest 2 just arrived and I went through the first instruction bit and then it started updating but the bar isn’t moving at all, is this normal?

@cbennz Same here.. Just got it & after setup.. Its showing updating but stuck at 0%. I plugged it in, still it won't start the update.

Honored Guest

I have recently brought myself a quest 2 and my initial update has been stuck for 2 hours now is there a fix? 

I'm in the same place been trying to update it for 3 hours now. Any luck? 

Best onboarding experience ever.. Right. They have no fix for this as of now. No idea when this will be fixed


I have the same problem. I bought Oculus today. Solutions from help website are not working 😕 

Yeah I'm still struggling to find out how to fix this issue for over 6 hours now, my brain is running low on juice. 


@MetaQuestSupport please look in to this.. It seems every new user who has bought a new quest2 is having this issue. Atleast give an option to skip the update.. Let me use my Headset atleast. 😑🙏

I don't know man.. Wondering if we will end up with bricked Quest2..