Showing results for 
Search instead for 
Did you mean: 

Solved - Quest 2 First time setup Stuck at 0% update


Just got a new quest 2, started setup, paired, got a new update. But its not at all updating.. Its been 4 hours.. Still at 0% 👌😒.



Retired Support

Hey everyone! Engineering is aware of this issue, and is currently working on a fix. We don't have a specific timeline on when the fix will roll out, but we appreciate your patience as the team works on it!

UPDATE: The fix is currently being pushed out. Please complete a power cycle and make sure the headset is charged before attempting to update to complete set-up.

Have you tried turning it off and on again?

Honored Guest

Someone mentioned on reddit that manually updating it to version 40 will fix it but I am too worried to try! First ever big purchase for me!

Do you know how long to resolve?

Honored Guest

Same issue here. Tried everything. Hotspot, wifi Channels, other DNS, created new Facebook account.... **bleep**. 

Is it a server issue.... Please fix ASAP. 👍

Honored Guest

I downloaded the app to my phone, linked my facebook account. The Phone App connects to quest 2, and you can change the wifi and see the batterylife of the headset and controllers etc. Its the headset that is stuck trying to download the updates.

So will there be any sort of discount or reward for us users that went and bought it today to not be able to use it?

I've been waiting for almost 10 hours

It's a joke, right now it's just a £400 paper weight, I've only been waiting 5 hours so god knows how some of you must be feeling 


I just received my new meta 2 and I’m having the exact same issue. Restarted. Rebooted. Factory reset and everything. Tried my router and my hotspot. Just waiting for it to charge past 60% and try again before I give up completely. 

Honored Guest

I've been waiting for 10 hours. Tried restarting and everything. 

Changing wifi doesn't work too