Showing results for 
Search instead for 
Did you mean: 

Stuck at charging with the right blinking red and white alternately


My oculus quest 2 was out of electricity for a few days (maybe half of a month) and then I charged it with my iPad charger (which is 20w). I used this charger several times before and they all worked well. So I thought this time would be the same. However, after a few hours, I thought the quest 2 was fully charged, so I turned on it and found that it didn't respond at all.

Then I used my iPad charger again, and found that "My quest gives a red blinking light, so I tried charging it. But when charging the red blinking light stops after a few seconds and goes solid white (meaning the screen is on). Its trying to boot up... Then the loading screen shuts off again and the light starts blinking red. This just goes on and on whilst its plugged into the charger. When I remove the charging cable nothing, but actually nothing happens. ", which is same as this problem.

Martijn said he/she solved this problem by changing the charger to the original one, so I did it so.

But nothing changed at all, the light is still blinking red and sometimes goes solid white.


What should I do to solve this problem?

Thanks for your help!


Community Manager
Community Manager

Hey there friend! 


We're grateful for you bringing this issue to our attention. We understand how much time you have put into this, so we would like to step in for you. 


The first thing we would like to bring to attention is the charging cord itself. We noticed you were using a third party cord to charge your device, at times this can work out for our gamers but not always. 


You also brought to light how you used the official Meta Quest charger, and you were still experiencing issues. Let us take a closer look into your cord. Do you happen to see any abrasions or debris surrounding the cord? Also have you been able to use a different wall outlet? 

[ You can share a snapshot of the cords you're using so we can take a look with you


We went ahead and listed down below troubleshooting steps we believe will help us out here. Follow along below: 


  • Overheated battery: When holding or wearing the headset you will not always feel heat. To solve this issue on your headset:
    • Turn off your headset by holding down the Power button until you see the shut down menu in your headset.
    • Select "Power off" from the menu.
    • Remove the charging cable from your headset and let it cool down for about 15-30 minutes.
    • Plug in the charging cable and see if it starts charging after having cooled down.
  • Hold down the Power button for 20+ seconds: Sometimes your headset can experience a bad state for different reasons. One solution is following: 
    • Plug in your charger cable. Then press and hold the Oculus power button for 20-30 seconds, which is going to force a hard reboot on your headset. 
  • Turn off your headset before charging: Sometimes our gamers can run into this issue when they leave forget to shut their headset off before charging. So try holding down the Power button until the shutdown menu appears in your headset and power the device off. Then plug in your charging cable and see if will charge properly. 
  • Factory Resetting Headset: Before completing this process please ensure you have 'Oculus Cloud Backup' enabled on your device. Click here: Oculus Cloud Backup | Meta Store


We really hope this information was useful. If you happen to run into anything please don't hesitate to reach out to us. We will always be here!


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I have the same problem and tried all those methods but it still flashed red , stops and turns to no light then comes back on and stays white repeatedly. Is it broken or what ?

Hey there, @La11y! We noticed that you are still experiencing some issues with your device even after attempting all of the previously mentioned troubleshooting steps. We definitely understand how troublesome that can be and we'd love to help you get this issue sorted out as quickly as possible! We would like to get you over to our dedicated Support Team so that we can do some more extensive troubleshooting with you. Please click here to connect to a specialist so that we may further assist you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you 

No need to thank us! We want to make sure your experience with us is running smoothly and be able to see you back in the VR world. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Yeah mine ain’t working my meta quest 2 isn’t even alive it’s at 0% I can’t turn it on at all. So how am I supposed to turn it on and factory reset it?? I also tried hard rebooting it but it wont do it. Anything else I can do?

Heya @AJPlayz_15! I know this has been affecting quite a few users, and I'm happy to lend a hand!


If a reboot didn't work, then a factory reset would definitely be the next step. You actually want to have your headset fully powered off before a factory reset, so turning it on first shouldn't be a problem. 

For a factory reset, make sure your headset is turned off, then attempt the following:

  • Hold the power and volume (-) button on your headset down simultaneously until the boot screen loads on your headset.
  • Use the volume buttons on your headset to highlight Factory Reset and press the power button.
  • Use the volume buttons on your headset to highlight Yes and press the power button.


If the boot screen doesn't come up, you aren't able to complete the factory reset, or it doesn't fix your power/charging issue, then you're going to need to either open a support ticket or send a private message to @MetaQuestSupport to take a closer look into what options are available for you.

Make sure you smash that Kudos button!

Yes I did that but as I said it’s completely dead and won’t turn on. Anything else? Should I use a different kind of charger or?

In that case, you're going to want to get in touch with support so they can get some info from you to look into possible warranty options for you.

There are two ways you could choose to do this! If you'd like to start a support ticket, you can follow this link, and select the closest options until you are prompted to reach support: Alternatively, you can send @MetaQuestSupport a private message.

Make sure you smash that Kudos button!