Showing results for 
Search instead for 
Did you mean: 

The "Enable Oculus Link" button doesn't show up after allowing headset access to my files.

Honored Guest


So I am trying to connect my headset to my laptop for the first time. When I click the "Link (Cable)" Method on the Oculus app, it then prompts me to connect the headset with a USB-C and USB-3 cable, which I do. Inside the headset, I get the message "Allow access to data: The connected device will be able to access files on this headset." I press "Allow." According to three different articles/videos about connecting the headset to my PC, I should then immediately get prompted with a message saying "Enable Oculus Link", but it never shows up on mine. Likewise, on the computer, the Oculus app just continues to have the waiting circle spin waiting for connection. I also have air link turned off. When I try to connect via air link, it also doesn't ever connect.


I specifically got the Quest instead of any other VR headset because I knew that my laptop wasn't very powerful and I needed a stand-alone headset, but I believe my hardware and software should still be capable based on their listed standards. I have Windows 10, an i7-6500U CPU, an Intel(R) HD Graphics 520 GPU, and 16.0 GB of memory. The cable I'm using says it supports high speed charging and fast data transfer:


Additional question: After plugging it in, my computer wants to know what to do with the device. Should I press "Import photos and video" with Photos, "Sync digital media files to this device" with Windows Media Player, "Open device to view files" with File Explorer, or "Take no Action"?





Honored Guest

To use the Link function, even if it sounds counter intuitive, you have to DENY access to data in Oculus quest when the prompt message shows.

I had the same problem... And the documentation is not very clear about it.

Also, If you Enable Airlink (a good alternative to the cable) then the Link thru cable will not be available.... You need to Disable Airlink for the Link thru cable to work.


Airlink works pretty good... It is under Experimental Features in the Configuration menu of your Oculus quest.


Hope it helps! 

Honored Guest

Just read that you already tried airlink. I had to reinstall Oculus drivers for it to work. It is recommended that the pc is connected to router via ethernet cable.

I'm sure you already tried rebooting everything also... Both the quest and your pc.

Yeah, if I press "Deny access to my data", it still does absolutely nothing. I didn't mention it in the first post, but someone told me the same thing and it didn't work yesterday and it still doesn't work today. (Yes, my airlink is off when I try to connect via cable.) Also, airlink also doesn't work. They're both connected to the same wifi, but the headset never finds the computer and vice versa. (Also I just checked, and my Oculus driver seems to be up to date.)

Hi friend, we see that you've encountered some issues with the Airlink feature, and we'd love to assist further! We noted that you've already performed some troubleshooting steps, which is awesome!


Next, we'd like to ensure that your headset is set up to perform one more final step to see if this resolves the link issue you've been experiencing. We'd like you to confirm that your headset data is backed up to the cloud so that you'll be able to retrieve your information later. In addition, we recommend performing a factory reset on your headset to refresh the software in hopes that it resolves the link issue.


If the issue persists, then we'd highly encourage you to reach out to us directly on our Oculus Support page so that we can seek the best solutions available to you. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I believe that integrated gfx do not support VR