Showing results for 
Search instead for 
Did you mean: 

Trouble connecting via airlink Plz help

Good evening everyone.

Just got my Quest 2 yesterday and have been setting it all up today.

Hardware wise I've got:


i7 10700k

Tp-link Ax1800 4-Stream Dual Band Wi-fi 6 Router


I had no issue connecting the headset to the 5gh internet currently not being used in my house and everything works find on that end.


I was able to connect the headset to my PC via link cable and that worked fine.


But when I try connecting to the PC wirelessly via airlink, it's a never ending cycle of searching for PC.


Modem and Router are no more than 6 ft away from desktop and headset.


I did make sure that the air link option was turned on under experimental.


Currently trying the repair method of the desktop app in the hopes that this works and will update if it does.


Slight update. Using Virtual Desktop instead of Airlink, VD shows that the PC and Headset are not on the same network. So now I'm even more lost as I followed the steps on setting things up found on this site.

So computer and quest 2 have to be on the same bandwidth.  Meaning if you are on 5ghz with laptop or pc, the quest 2 needs to be on 5g.


Also the best way to run wireless air link or vd, is to have the computer hard wired to router.


If you have 2 routers going it will cause conflict.

I have the router/modem, not sure which it is anymore lol, that I got when I signed up with my ISP and the AX1800 that I bought specifically for my Quest.

I did figure out the issue. I needed to reset the AX1800 and actually do the setup process, from there I made a new network name and have both the PC and Quest connected to it. Tested on both Virtual Desktop and Airlink.


Everything worked fine on Virtual Desktop. But with Airlink, while I was able to finally see the PC on the list through the Quest and click pair, once I click pair nothing really happens, it just sits there with a dull blue Launch button I cant press.

for airlink when you paired did you see a code pop up on your computer?


i find i have to sometimes resest experimental settings from time to time.  also i remove the device with in the oculus pc app so it can start freash.


also depending on firmware/oculus pc software versions i have to toggle on/off beta in oculus pc app.

Yeah, turns out I needed to restart PC and Quest, then I could connect np

So how is it working out for you?

Working great now.

Just fiddling with headset to find best comfort fit and looking through games