Showing results for 
Search instead for 
Did you mean: 

'Unable to confirm Oculus account' error since moving to Facebook

Level 2
I recently converted my oculus account to Facebook as 'encouraged' by Oculus.  I can no longer access my Oculus games, although I can run the external game 'x-plane'.
My library seems OK on the desktop, but when I put my headset on, I get the message "Unable to confirm your Oculus account please check your internet settings  or restart Oculus".
I have tried uninstalling Oculus and re-installing but I get the same error.

Any advice would be most welcome

Having this issue too, did you ever get it sorted?

Level 2

I am having the same problem. I have been going around and around with support for months. No one can offer anything more creative than "please update your computer now please delete and reinstall oculus oh make sure you are logged in to your facebook account now you need to run more updates and plug your computer directly into the router because we see wifi errors" and on and on and on and on but NONE of it has made one iota of difference. I've already exchanged my RiftS once, thinking it was the headset. Nope. New one did the exact same thing. Geek Squad has confirmed my computer is fine and well above spec to run the RiftS. My wifi is 300Mb, comfirmed at the computer. So that only leaves one thing... and Oculus support has not helped at all. Just more of the same every time.


Hi did you figure it out yet?

Level 4

You need to start the Oculus desktop app and log in using your Facebook account. Check that your Facebook settings aren't blocking the linking to your Oculus account. Also make sure the app isn't being blocked by your antivirus, firewall, hosts file, Peerblock or any other program that blocks network traffic. Good luck.

Level 2

This just resolved this issue for me 


Go to
Click menu icon / Drop Down menu from top right
Go to Settings > Settings
Go to Apps and Websites
Under Apps, Webpages, and Games, click 'Turn On'. You may need to first turn this off, then turn back on.
Restart headset and computer and try again.

Not applicable

This fixed it for me - brilliant, thanks!  Oculus support were clueless and just asked me to uninstall antivirus, check my internet connection and all the usual rubbish, despite the fact I told them I could access the Store, my Library and all the other 'apps' so it wasn't a connection or general authorisation problem.  My issue was just accessing the Oculus Home when connected to my PC that was failing.  (Oculus Home in the headset worked fine - just not when connected via Airlink or Oculus Link to the PC.)

Doc-Jam, you are a legend! This has been driving me mad for ages.. Thanks for sharing your knowledge.. 😁

Level 2

I have the same problem and idk how to fix it 

Hey there! We'd love to help you get back into your account so you can have fun again! Please PM us by visiting our profile, or click HERE to reach out by email or chat, and we'll take care of you. Thanks!