Showing results for 
Search instead for 
Did you mean: 

displayport connection not working + no displayport connection

Honored Guest
I already tried plugging in the USB cable first, waiting for the light to show up, then plugging in display port.
I am 100% sure that it's connected to my dedicated graphics card.
my rift s is up to date and so is my computer.
I already have installed the latest Oculus drivers.
I tried restarting the Oculus app.

this problem is so irritating that just throwing the headset outside the window would make me feel better.
Please help me fix this problem

Community Manager
Community Manager
Hey @"kalvincritch.vicenio" try removing the facial interface by gently pulling on it, and reseat the cable behind it. Other steps would be removing other USB devices, leaving only your mouse, keyboard and the Rift S as well as updating your graphics drivers. If the issue persists, you can gather your diagnostic issues and create a ticket further assistance. - Principe
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!