cancel
Showing results for 
Search instead for 
Did you mean: 

v46 frame drops/stutters/headroom dips

NumbrOneDad
Level 4

Edit: For anyone stopping by looking for a solution, there isn't going to be one. This issue is falling on deaf ears by meta staff. The issues described exist both in standalone and pcvr link/airlink. It seems to be widespread, possibly most or all quest 2 devices, yet it's been relayed that it's only a small subset of users experiencing the issue... sure. That's definitely why we can totally troubleshoot and fix it /s

The only remedy is going to be through an update issued by meta. I/You/We have done all the troubleshooting and bug hunting possible, all signs point to them. Good luck everyone!

...

Frame drops, reprojection (even with ASW set to Off), stuttering, performance degradation, and gpu headroom dipping to 0 or even negative has been since v44, and now v46 as well. I have come across this issue in many different posts here in the meta forums, elsewhere as well, and no one has come to any conclusions other than this HAS to be an issue with oculus software itself. Witnessing OVR errors and socket errors amongst others in the console logs and no previous fix is capable of providing any remedy to the current issue. I have tried all previous working drivers from nvidia, uninstalling with DDU and reinstalling old to new. No change. HAGS set to off, clean installed oculus based off of official support techniques (safe mode and manual folder deletion), toggled and focused console window, set high priority on ovrserverx64 and game running, disabled link sharpening, disabled mobile ASW, reset all graphic settings to default, set vsync to off in nvidia control panel, reset nvidia control panel, nothing. These issues stem directly from the oculus software and there's no chance of user error. For those hoping to chime in about windows update breaking the software, that is also untrue. I have now tried windows 10 on updates 20h1, 20h2, 21h1, 21h2, and 22h2 and this issue is present across all of them. I also tried on windows 11 builds 21h2 and 22h2 and the same issue persists. We desperately need a community update from @Ryanality as i know im not the first to raise this issue. I wish i could say it was just user error, machine setup etc. There are multiple internal errors displayed in the console window and i've submitted these logs with the support team as have the others experiencing this issue. It would be great if we could PLEASE get a public update regarding this issue. I have been troubleshooting this for several weeks straight.. i'm going absolutely mad. PLEASE HELP US!!!!!!!!!!!!!!!!!!!!!!! Basic troubleshooting, clean installs, NONE OF IT WORKS! 2 years of using this headset and software...and this is the worst its been by far! 😧

226 REPLIES 226

Gool54
Level 2

After latest update when i play Rogue squadron for about 30mn the color red, blue start to bleed, i dunno of anyone has noticed that when i turn off quest 2 and it cools down its back to normal ?  anyone ? 

HomidWay
Level 6

Pc Specs : Win 11, Ryzen R5 3600, RTX 3070, decent 5ghz router.

 

I've tried a lot of common solutions and none did anything.

I'm having:

  • A lot of microstutters even not in game
  • Oculus Dash droping frames BELOW 0 even if game was running (relatively) smooth
  • Ocasional freezes ut to a second
  • Random long lasting moment of dropping frames

Temps are totally fine gpu is not getting more then 60-70 degrees, cpu even less around 60 as it being cooled by water.

PSU is providing enouth as this behaviour happens ONLY in VR games, and can happen as in demanding games as HL:A or just some not that demanding as is Blade & Sorcery.

As for connection, i use Air Link, in everything exept for encode res  is on default, and encode res manually set to be 3680 as it anyway defaults to that on 90hz, render res doesn't change anything and problems still appear.

And router is providing more then enough to feed even 200 fixed, let alone dynamic.

Am I missing something? Like i had rx 590 and it didn't have such drops and freezes on this same system, but rtx 3070 does.

My speed inside questMy speed inside quest

I've tried with a longer session and...

While the tracking is a little bit better it is now dropping so many frames that it's became an almost constant stuttering, so it's still unplayable.

 

Imo, if this will be fixed the tracking will be better than it was before (when there were no encoder issues)

 

Meta, fix the PC software, it's weeks without a fix now.

RelicUK
Level 4

Bit of a development. If you enable the public test channel in the beta tab in the Oculus PC software, it does help a lot! However it is still stuttering and not like it was before at all. But it does help, so at least they are trying to improve this

HomidWay
Level 6

Having same issue, confirm if that what you having

ryzen 3600

RTX 3070

Wow! That is FAR worse than what i've been experiencing. It's definitely similar, but your headroom drops are far more sporadic than mine were/are. Curious as to what your troubleshooting steps have been thus far. Drivers? ASW disabled? C State disabled in bios? Air link or link cable? Try updating to the PTC and see if your issue gets a little better or if it stays about the same.

 

It seemed helped for a short while, but it eventually starts acting up again. I noticed it was FAR worse in boneworks via the oculus store than it was playing HL:A on steam. Still having stutter and consistent frame drops but the issue of ghosting/reprojection feels slightly alleviated. I still notice errors in the console log about frames dropping due to encoder backup, so that still hasnt been resolved. Also, the VADshader error still unable to open mutex or whatever. Also, i've noticed a warning popping up in the console about OVRserver exceeding 128mb, which means there may be a memory leak on top of it all lmao. These past two updates have been A MESS YIKES. I hope they continue issuing updates via the PTC so we can continue to troubleshoot and compare. I hope these updates are in regards to our complaints and not just some fixes for the quest pro...

edit: i've collected and submitted more logs from an extensive play session. Hopefully you all are doing the same!

fatal88
Level 6

On air link it's even worse for me with v47 PTC. Doesn't even need to move my head anymore to get constant framedrops on the desktop. I will try tethered later, but for room scale games it's not an option for me, I don't have the space on the room where the PC is.

 

I've opened a support ticket, they replied to turn off the integrated gpu. I wrote in the initial ticket that I have a 5900x which doesn't even have one lol.

Tryed to play around with settings of games, disabling OC and pushing it further to make sure it's not actually hardware underperforming, changed wi-fi conigurations, did try ASW on/off, Mobile ASW on/off and different combination of those, tried to force HEVC with reg edit, tried to force AVC with reg edit, complete reinstall of Oculus software, clean driver install, did play with vsync options (Fast is the worst one by the way), tried locking fps with rivatuner on somethin slightly lower then display refresh rate with ASW disabled.

Read about this myght be audio related as if you switch Oculus headset as default playback device, nope.

Read about one guy having Link Sharpening disabled fixed problem, not for me.

Temps not an issue as both gpu and cpu below 60, and most important 

ALVR and Virtual Desktop PERFORM NORMAL.

I hope that this will be fixed soon, literally bought headset first and upgraded gpu next week after to have smooth gameplay, to have this.

How did you force AVC on Air link, what registry key should I insert or alter? Someone on reddit said the new PTC fixes the problem in link for him, but not in Air Link. Air link uses HEVC by default, I want to check tethered link and if it's OK, I wanted to see if it solves with AVC in Air Link as well.

 

It's not audio related and game FPS also not the issue, it's encoder problem, meta modified something in v46. Disable link sharpening only helps on a Quest 1.