Showing results for 
Search instead for 
Did you mean: 

your device is corrupt. it can't be trusted and may not work properly.


Hey everyone!

So today i turned on my Oculus quest in the morning and got this message "your device is corrupt. it can't be trusted and may not work properly".WhatsApp Image 2021-04-08 at 14.56.46.jpeg

Very annoying thing is that it always pops up and for some reason my developer mode is gone and i cant activate it any more........

Tried doing a factory reset - dosent work it just restarts the headset to that message and after a while it boots up.

Games and stuff still work with no problems. But i need the developer mode more than my games for work.



Nevermind! i fixed it by myself. 
this is what i did:
  1. downloaded adb fastboot — installed it
  2. on my cell phone in the oculus app activated «Developer mode» but it didnt active in the headset
  3. Connected the headset to my pc via type-c
  4. Opened CMD on my computer as admin
  5. typed adb pressed enter
  6. typed adb reboot «dm-verity enforcing» pressed enter
  7. Headset rebooted and the message disapeared and now i can see «Developer mode» 

Hope this helps if anyone has the same issue as me this morning.

Have a good day everyone


Honored Guest

sadly it did not work for me 😞

Honored Guest

This worked for me. Thank you!
Just in case you're confused, you need to replace « and » with double qoutes (").

Kind regards

I owe you a beer or tacos or at least a big hug .. THANK YOU