Showing results for 
Search instead for 
Did you mean: 

OpenXR Runtime

Honored Guest


When trying to play any games on-air link which have worked perfectly in the past now won't work. It brings me to a black screen because my OpenXR needs to be set to active, in which case it's not. I tried clicking set oculus as active and it does nothing. I Tried looking at some things online and couldn't do too much about it. I have an image of what it says for reference. Any suggestions help. Thank You.Capture.PNG


Honored Guest

I ran into this problem just 3 days ago. I did a cold boot  removed my steam app from running then was able to set the Oculus as active tic. It greyed out ever so slightly its been working since then. Good lucky I have windows 11

how did you cold boot the Oculus app? Did you uninstall the steamVR app?

I meant I pulled power from the PC and rebooted both. Then I removed all steam applications from running in background. I then restarted the oculus app and hard wired my headset. It asked me again to change the settings and I was able to click it. 

Honored Guest

So the answer is that it won't let us set it if we have steam installed? 
That is ridiculous if true. 

No, it means if Steam has become the active OpenXR app you just need to regain control via the Oculus app. It's very simple to reboot your PC without Steam running and restart the Oculus app to be able to set it.

Even that isn't always needed. Right now I'm swapping back and forth between WMR OpenXR, SteamVR OpenXR and Oculus OpenXR.

WMR's Mixed Reality Portal (which the OP was running apparently) needs to be closed and reopened to detect it's lost control, since I can't find an option for it in the settings (need to restart it so the warning with a button appears). Oculus and SteamVR just need to move to another tab in settings then back and it will refresh.



Anyway, back to the op's problem, OpenXR isn't needed for Airlink. Right now I've got OpenXR set to my WMR Reverb G2 headset, but Airlink with my Quest 2 is working fine.

OpenXR is only needed for OpenXR games, which are pretty rare at the moment.


Perhaps it's an admin thing. What these OpenXR settings do is just change a registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1 to point to a json file for WMR, SteamVR or Oculus. That may be failing if you aren't using an admin account.

So do you need openXR installed on your device to run these openXR games, because i have watched many videos on how to fix it and nobody said, that you need to have openXR installed

OpenXR doesn't really have a separate install. Meta, Valve and Microsoft have each made a version that now comes with their headset drivers. When an OpenXR game starts, it checks the windows registry to see which OpenXR provider is the one to use.

For example, the actual OpenXR implementation is located at:

Oculus: C:\Program Files\Oculus\Support\oculus-runtime\LibOVRRT64_1.dll

SteamVR: C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\vrclient_x64.dll

WMR: C:\Program Files\WindowsApps\Microsoft.WindowsMixedReality.Runtime_112.2211.2002.0_x64__8wekyb3d8bbwe\x64\WinXrRuntime.dll

As long as you have up to date drivers for your headset, it should be good to go.