cancel
Showing results for 
Search instead for 
Did you mean: 

BUG in Oculus GO with Avatar SDK not showing OPENGL NATIVE PLUG-IN ERROR

treeviewstudios
Level 4
Hello Oculus community, i just found out that in Unity 2018.2.14f there is a bug with Avatar SDK, when you open the cross platform sample scene in the oculus integration pack, in the oculus go you wont see the avatars, if you set the textures to ASTC they will appear shortly and then disappear , but the hands will be showing.

In the logcat i get :  OPENGL NATIVE PLUG-IN ERROR: GL_INVALID_VALUE: Numeric argument out of range
and
 Graphics.CopyTexture with a region will not copy readable texture data for compressed formats (source texture format 50)

I am going to test Unity 2018.3 beta to check if it works, if anyone has any idea whats happening ...
5 REPLIES 5

treeviewstudios
Level 4
Ok i got the avatar working, i can see them and stuff, but the floor is wrong, they are like 1 meter down.

cloud_canvas
Level 5
@treeviewstudios are you setting the root of their transform to Y+1.5? I believe this is the recommended practice from the guides provided by Oculus.

treeviewstudios
Level 4


@treeviewstudios are you setting the root of their transform to Y+1.5? I believe this is the recommended practice from the guides provided by Oculus.


This is my fix that works kindda better and cleaner than adding a transform..
https://pastebin.com/wUvmbpLd

Instead of setting the object child of another and adding an Y offset, send +1.5 to the avatar sdk 'C' api by adding the Y directly to the method that calculates the Y position

#if UNITY_ANDROID && !UNITY_EDITOR
           
            headPos.y += Core.GameSettings.Instance.OculusGoPlayerHeightOffset;
#endif

that way you dont even have to touch Remote avatar driver or anything.

im on discord if someone else needs help.

Manzalab
Level 2
Hello!

I'm having the exact same issue the thread is named after. The avatar's mesh loads without textures, then disappears, leaving nothing but hands. The same error messages appear.

I'm working with the 2017.4.19f1 Unity version. If @treeviewstudios managed to solve this, I would be very interested in hearing how he did it.

Any help?

Thanks!

treeviewstudios
Level 4
Hi @Manzalab
You mean this solution? https://forums.oculusvr.com/developer/discussion/72576/fix-avatar-body-mesh-not-appearing-loading-in-unity-oculus-go#latest