cancel
Showing results for 
Search instead for 
Did you mean: 

MotionController events not available in EventGraph of Blueprint

VizSource
Level 2
Right click in eventgraph "All actions for this blueprint" does not have any MotionController (X) events.

We followed these two guides from oculus and unreal.
  • the Oculus Go Unreal Quickstart
  • the Unreal Online Course "Creating Virtual Reality Walkthroughs"

Platforms
  • Unreal 4.24.1 Version: 4.24.2-11100242+++UE4+Release-4.24
  • Oculus SDK 1.41.0
  • Oculus Go
  • Windows 10
  • Working and tested together on other projects
We tried the Oculus branch of Unreal Engine and the Unreal installer version and have the same result.

Steps to recreate

1. Create new project Games, Blank Blueprint Project (follow the steps from the Oculus GO Unreal quickstart)
  • Mobile
  • Scalable 2D/3D
  • OculusVR plugin
  • No starter content
  • etc...
2. Configure Pawn and controllers, following the steps in the "Creating Virtual Reality Walkthroughs"
  1. Add a Blueprint Pawn, named "VRPawn"
  2. Add a Scene
  3. Add a Camera to the scene
  4. Add 2 MotionControllers, to the scene
  5. Configure MotionControllers for Left and Right Motion Source
  6. Configure MotionControllers for Visualization Display Device Model default
  7. Add a Blueprint Game Mode
  8. Set the default pawn class to "VRPawn"
  9. Save and compile
  10. Play the scene, and launch it on the Go. No errors
  11. Open the "VRPawn" blueprint
  12. In the Event Graph, right click and type "MotionController"

Expected result
See options from developer.oculus.com/documentation/unreal/unreal-controller-input-mapping-reference/
for GO controller, such as
  • MotionController (L) Trigger
  • MotionController (L) Thumbstick
  • etc...
Actual results
No listing for any MotionController (L/R) input.


Requested Action

Describe the steps required to be able to use a Oculus Go MotionController event in a blue print.

Thanks,

Mark
9 REPLIES 9

VizSource
Level 2
I found this in the release notes for 4.24.
I reverted to 4.23 and the MotionController (X) is there.

What are the mappings for the new "keys specific to each controller model" for the Oculus Go?

The Oculus page developer.oculus.com/documentation/unreal/unreal-controller-input-mapping-reference/ still refers to MotionController (X), even though the Oculus Unreal branch has moved forward to 4.24?

Is there other documentation that is maintained?


Unreal 4.24 Release notes

XR
Action bindings that use MotionController keys need to be updated to use bindings for each platform the project is targeting. Blueprints that read MotionController keys directly need to be updated to use the action system instead.

Deprecated: MotionController keys are now deprecated and have been replaced by keys specific to each controller model.

GameOnTrainer
Level 2
I just ran into this as well and found a hacky fix, works but not without a compile warning. Here's the steps:

Pawn blueprint/Event Graph/Right-click search for 'gamepad right trigger'
In the trigger details change Input Key to 'Oculus Touch (R) Trigger'

It works but I get the following warning, InputKey Event specifies FKey'Oculus Touch_Right)Trigger_Click' that is not blueprint bindable for Oculus Touch (R) Trigger << ANYONE KNOW HOW TO RESOLVE THIS?

imvirtual
Level 3
Hey, just ran into this too!

The way to do it is add input action mappings for the controller buttons, then use these bindings in the event graph to call your functions. Simple as that.

This new method allows you to setup your project to work with different controllers very easily..


In the example below you can see a setup for TriggerRight (as well as some others as I'm using on Oculus Touch and others as well)

In Project Settings --> Engine --> Input5u7yd32c9gbj.png

71s8fl3mypdn.png

dtsvr
Level 2
Thank You imvirtual ! I am doing the "Creating Virtual Reality Walkthroughs" course with UE 4.24.3 and this had me stuck. Cheers - Fred

Noobala
Level 2
Is this fixed in 4.25?

gaston_zuazo
Level 2
imvirtual thanks a lot!

Spoon420
Level 3
I am having this issue but other people I have talked to are NOT having this issue. I also tried 4.24 4.23 and 4.22 and they are all having this issue. I'm going to try a fresh install of windows and I suggest the same to anyone else having this problem. Don't wait for it to "get fixed" because the problem isn't on their end it's on our end.

Anonymous
Not applicable
? no need to do a windows re-install - just follow the steps in this post:

Thank you!