Showing results for 
Search instead for 
Did you mean: 

New oculus Update make the controllers not work in UE5


After the recent Oculus Update, my controllers have stopped working in Unreal Engine 5. whenever I try to play in the editor or a working project build, the controls do not move or allow for input. They were working perfectly before the update. This is affecting the Oculus Rift CV1 and the Quest 2.

From what I've read in the forum so far all Oculus headsets are affected and Facebook/meta are sitting on their hands doing nothing


Both controllers are fixed to 0.0.0. in the world space and won't move or allow for inputs 

Two and a half years of work are now dead in the water until it's fixed.




I have tried uninstalling and reinstalling the Meta desktop app. 

I have tried different solid builds that I know work. 

"Have you removed any third-party accessories that may affect power, battery fit, or controller detection. For example, rechargeable grips, controller covers, etc." - Yes

"in your other attempts, did you unpair and repair the controllers to the headset?" - Yes

"Have you checked the controller battery and the LED status (blinking, solid, or no light at all)?" - Yes

I have a custom build development PC that can more or less handle anything so that isn't a problem.


Honored Guest

Same problem here. Tried even with new projects (no code or modifications) and nothing. The Meta XR plugin only helps to recognize the controllers in Blueprints, still with no tracking.


Same here, but it's broken my CV1 both in the editor and in a public live app. Ongoing development has come to a crashing halt.

I've also tried other apps, all of which have worked so far. My hands appear in the VR hub too.

I've also tried rolling back to a known-good release which doesn't work. The game starts, but the controllers aren't present.

I'm using the OVR Plugin with Unity, and the OpenXR plugin for the upcoming Steam release. All are broken.

I don't see any errors from anything in the editor. I have no idea how to trace this problem, let alone fix it.

It all used to work fine. Now it doesn't. I've changed nothing. Meta? What did you do?!



This has also been noted on the player/consumer side of things as well, but nothing has been said from Meta yet as to a fix.


Thanks for linking that @ProjectAce, I've added a more detailed post on there with a few extra things I've spotted


Seeing the same problem, glad I found this thread on it. 


If anyone doesn't know, this is now fixed. You might have to use the "public beta" setting to get it working before Meta pushes an update to you.

Yes controllers are working fine now in the editor, thanks