Showing results for 
Search instead for 
Did you mean: 

Asgard's Wrath stuck at initial loading screen

Using Quest 2 and link cable, I finally got Asgard's Wrath to finish downloading. Unfortunately after I start the game then choose my motion preferences, the next screen showing creation of the world, the game just stops there and never proceeds any further. I've tried turning the headset off and back on several times. Once, on the creation screen I at least got some text shown in the box, but then it still wouldn't take me into the game. I'm not sure what to do or try, I did a Google search and found another person had this same issue but there weren't any responses to their post.

Also I did download the Steam VR system test app and it stated my computer met and/or exceeded the benchmarks to play Steam VR games without issue. After the test it shown a bar ranging from red/yellow/green and my PC hit the green/good portion. 

Anyone else had this same issue or at least know of any things I can try ?

Honored Guest
facing the same issues. I have no idea what went wrong. After I optimized it using geforce experience, it just didn't run after the save file screen. 

Eventually I was able to get past that initial loading screen, although I had to wait a very long time, longer than it normally should take to load. 

I was able to get to the first action sequence to fight the Kraken, that part played out with absolutely no issues whatsoever. Then after defeating the Kraken and going to the inn, I got issues with chopiness and longer than usual load times. 

I had tried restarting headset, and firing the game back up. Some times I'd be able to get past the loading screen having a saved game, other times I would get back to the inn and the chopiness would make the game unplayable. 

I tried to move onto the next section of them game to continue a quest, and then get stuck at that loading screen and not able to progress. 

I just dont understand why some parts of this game would work as intended sometimes then other times be unplayable. I'm using the official link cable also. My Nvidia card says my PC should run VR no problems. The Steam system test thing you can run also said my computer should be able to run VR with no issues. 

Anyone ? 

Super annoying that my PC is showing it can handle VR with no major issues and using the official link cable and this game is unplayable.