Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 Windows 11 Performance. can never hit maximum FPS with link cable.


I decided to give windows 11 a go and everything on my PC is working flawlessly apart from one big one... Oculus Link performance. Before I go back to windows 10 I wonder if anyone has figured this out already.


Oculus software works fine and the Quest 2 link connects, but it can never hit the required fps settings no matter what they are. So if I have link set to 90hz, then in game it will be about 82-85fps and stuttering, it never hits 90fps even though the game says its locked at 90 on my monitors no problem, and I have loads of headroom in performance monitor (I have a 5900x and RTX 3090!) - If i use the 120hz option then i will get about 105fps but never 120. Even if i choose 72hz ill get about 65fps. super annoying.


I went onto the beta channel on the software and got the latest updates but still no luck.


I dont mind going back to windows 10 and i get windows 11 might not be ready yet, but literally EVERYTHING else on my pc works fine, only the vr performance, so its a shame. Any ideas of things to try before I reinstall windows 10?

453 REPLIES 453

Thanks for advice I will try tonight! 

without an Oculus update I cant see how tbh... anyone else that previously had issues can confirm?

It could be because of the performance issues with AMD Ryzen CPU's on Windows 11. Microsoft apparently just released a fix for one of the issues in an Insider build. So the problem could have been with Microsoft and not Oculus.

As I recall, all the users in this thread, who posted their PC specs had Ryzen CPU's. Correct me if i'm wrong.

Oculus Quest 2, Ryzen 7 5800x, 32GB RAM, RTX 3090.


Interesting.. yes I am indeed on a 5900x
However on the windows 11 build I was on i did before and after benchmarks with windows 10 on regular games and got identical results, so not sure what the ryzen performance issue was or if it was introduced in a later build

I'm on Intel and also had issues on the release version on Windows 11. I tried the console fix and it worked but recently I updated Windows and tried Link without the console being visible and it worked perfectly again. Would be awesome if someone else can try on the latest version of Windows.

If I am correct, the fix for the ryzen performance come thursday (I'm not using insider build)


but it seems the issue is not only on Amd Processor.


I will try to update it costs nothing 🙂

could you please share with us which windows 11 build you are using?

I installed the latest windows 11 insider update (build 2200.282) that fixes the issue with the Ryzens but the fps problem still exists. I still need to toggle console visibily to play. I use ryzen 3700x and i thought this would fix it. but it didnt.

There is another patch coming from AMD on Thursday 10/21/21 to deal with the preferred cores which is chipset driver.

Sure. It's 22000.282 co_release. It was after 2021-10 the Cumulative Update for Windows 11 for x64-based Systems (KB5006674) that my issues fixed. The only other relevant things that I could think of is that I'm on the PTC on Oculus and I updated my drivers.